Last Comment Bug 868526 - Version uploaded while another version is PUBLIC_WAITING goes to wrong queue
: Version uploaded while another version is PUBLIC_WAITING goes to wrong queue
Status: VERIFIED FIXED
p=2
:
Product: Marketplace
Classification: Server Software
Component: Reviewer Tools (show other bugs)
: 1.0
: All All
: P3 normal (vote)
: 2013-07-18
Assigned To: Mathieu Pillard [:mat]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-03 11:48 PDT by Rob Hudson [:robhudson]
Modified: 2013-07-18 08:05 PDT (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Rob Hudson [:robhudson] 2013-05-03 11:48:34 PDT
When a new app is uploaded and the app has a prior version that is approved but waiting, the new version should appear in the updated queue.

What happens when the dev has 2 approved but waiting versions is another question. See bug 867570.
Comment 1 Mathieu Pillard [:mat] 2013-07-04 10:05:22 PDT
When following those steps, I don't see the app in any queue. At all. 
Here is what I did:
- Uploaded v1
- Reviewed it, but changing the requirements, making the version approved but waiting
- Uploaded v2
- v2 never showed up in any review queue but it's shown as pending approval in the devhub

However, if as a dev I make the app public, it correctly swiches v1 to public and then v2, still pending approval is correctly sent to the reviewers queue.

I can try to fix that behaviour and make sure we always sent in the to update queue, but since you mentioned "wrong queue" I want to make sure what I'm seeing is coherent with what you had. Is it ? :)
Comment 2 Andrew Williamson [:eviljeff] 2013-07-04 10:26:41 PDT
I can reproduce using the steps in comment 1 on -dev.  Attempted both using an app where I chose delayed publishing on submission and for an app where I deselected a device so got delayed publishing just for that version.  In both cases the app showed up in the main submission queue.
Comment 3 Mathieu Pillard [:mat] 2013-07-04 10:32:56 PDT
I'll retry and fix.
Comment 4 Andrew Williamson [:eviljeff] 2013-07-04 10:33:57 PDT
https://marketplace-dev.allizom.org/reviewers/apps/review/blesuscri-idotilant-abertir
and
https://marketplace-dev.allizom.org/reviewers/apps/review/mezomcusings-britonzontack-

I note that for both of them the statuses of the APP is pending approval, not approved but waiting.  But after the first review the status is correct.  So I would therefore assume the problem is in the submission code - its resetting the status to pending approval if its approved but waiting.
Comment 5 Mathieu Pillard [:mat] 2013-07-15 06:43:06 PDT
Fixed in https://github.com/mozilla/zamboni/commit/fcb96aeb62a379a6923c0c00268c0d03087c0217

Steps to reproduce:
- Upload a packaged app
- Review it, but changing the requirements, making the app 'approved but waiting'
- Back in the developer pages, don't make the app public, instead upload a new version
- The app should still be shown as 'approved but is not public' in the developer status page, with one version 'Pending approval' and the other 'Approved but waiting'.
- The app should show in the updates queue in the reviewer tools
Comment 6 Victor Carciu 2013-07-16 07:49:24 PDT
(In reply to Mathieu Pillard [:mat] from comment #5)
> Fixed in
> https://github.com/mozilla/zamboni/commit/
> fcb96aeb62a379a6923c0c00268c0d03087c0217
> 
> Steps to reproduce:
> - Upload a packaged app
> - Review it, but changing the requirements, making the app 'approved but
> waiting'
> - Back in the developer pages, don't make the app public, instead upload a
> new version
> - The app should still be shown as 'approved but is not public' in the
> developer status page, with one version 'Pending approval' and the other
> 'Approved but waiting'.
> - The app should show in the updates queue in the reviewer tools

I followed your steps, the app is correctly displayed with both version in developer status page, but I was not able to verify last step because of bug 894394
Comment 7 Victor Carciu 2013-07-18 08:05:32 PDT
Verified as fixed last step too : http://screencast.com/t/XMYTMr8G

Note You need to log in before you can comment on or make changes to this bug.