Browser crashes if command-W is pressed at the same time a download is queued.

RESOLVED INVALID

Status

()

Firefox
Untriaged
--
critical
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: tomlgavg, Unassigned)

Tracking

({crash, stackwanted})

14 Branch
x86_64
Mac OS X
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
I save images frequently and try closing the downloads window that pops up by using the shortcut command-w after clicking save. When I do that, the browser crashes. Once I reopen the browser, the image finishes saving. 

This might happen with other file types also but it might happen frequently with images because they finish downloading quickly.

Comment 1

5 years ago
Please provide the crash ID (bp-...) from the about:crashes page.
Does it happen with Firefox 20.0.1?
Does it happen in Safe Mode (see https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode)?
Severity: minor → critical
Component: Downloads Panel → Untriaged
Flags: needinfo?(tomlgavg)
Keywords: crash, stackwanted
(Reporter)

Comment 2

5 years ago
I have tried reproducing this with the updated version and it seems to have been fixed. This seems to have been an error in firefox 14 that has been fixed. I was not aware that I wassnt on the latest version because auto-update was added in ff 16. I am sorry for creating a false bug report, especially since you tagged it as critical.
Flags: needinfo?(tomlgavg)

Comment 3

5 years ago
(In reply to tomlgavg from comment #2)
> This seems to have been an error in firefox 14 that has been fixed. 
I think instead you were using an extension compatible with version 20 but not version 14.

> I was not aware that I wassnt on the latest version because auto-update was added in
> ff 16.
Auto-update has existed at least since Firefox 3. Maybe you turn it off. See your update options: https://support.mozilla.org/kb/update-firefox-latest-version#w_how-do-i-configure-update-20optionssf21preferencessf
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.