Closed Bug 868607 Opened 10 years ago Closed 10 years ago

Hard to get the dynamic address bar to show on nightly

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox23 affected)

RESOLVED DUPLICATE of bug 868998
Tracking Status
firefox23 --- affected

People

(Reporter: kbrosnan, Assigned: cwiiis)

References

Details

Attachments

(1 file)

It is hard to get the dynamic address bar to show on nightly vs aurora. On aurora the address bar shows on almost any pan down action where as on nightly there seems to be a threshold. 

https://www.youtube.com/watch?v=VL9M4rmNAS4
tracking-fennec: --- → ?
Version: unspecified → Trunk
Assignee: nobody → chrislord.net
The address bar only opens when you swipe down from the top of the screen. Makes it nicer for full screen but harder to get the address bar back with out knowing its there.
Maybe I misunderstand what the blocking field should be used for, but does this really block bug 716403?
Meh, we just treat it for tracking all fallout bugs usually off an initial implementation (https://bugzilla.mozilla.org/showdependencytree.cgi?id=716403&hide_resolved=1). When we figure out what regressed this bug we can change it to the exact bug.
I remember that the early behavior was always displaying dynamic toolbar when user scroll down a page. I think this behavior is very simple for user and good for resolve this problem.
The issue is no regression but an intended change, see bug 865298. The toolbar is only revealed when scrolling up in the top *quarter* of the screen. 

I think it's a nice idea to be able to scroll up without revealing the toolbar, but I agree that the feature is hard to discover. Discoverability is escpecially a problem phones with big screens as user tend to scroll in the lower half of the screen, when they hold the phone with one hand, I think.

Maybe we can show a kind of overlay that educates the user when the toolbar is dismissed for the first time?
Blocks: 865298
No longer blocks: dynamic-toolbar
Flags: needinfo?(ibarlow)
Attached image Overlay mockup
I tried to create a quick and dirty mockup to show what I mean with 'overlay' (I had only Paint at hand, so this is quite ugly, sorry ;-)
It would definitively need some sort of user-friendly educational hint. Hoping that the user will accidentally trigger zone and make the link is unfriendly behavior. :)
Another option we are looking at is to reveal the title bar after you pull down a certain distance, say 40 pixels or so, from anywhere on the screen. We're going to compare that interaction to this one before we decide what we want to ship.
Flags: needinfo?(ibarlow)
Whichever the case, this should track 23+ if that's the target first release of the dynamic-toolbar.
We only need one bug to track this I think.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
tracking-fennec: ? → ---
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.