1 dock_test.js unit test fails on TBPL

RESOLVED FIXED

Status

Firefox OS
Gaia
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jgriffin, Assigned: crdlc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

188 bytes, text/html
Jose Manuel Cantera
: review+
Details
(Reporter)

Description

5 years ago
Error:

14:57:19     INFO -  gaia-unit-tests TEST-PASS  | dock.js > with 1 icon > looks ok
14:57:19     INFO -  gaia-unit-tests TEST-UNEXPECTED-FAIL | dock.js > with 1 icon > #calculateDimentions | expected 0 to equal 0
14:57:19     INFO -  gaia-unit-tests INFO       | stack trace:
14:57:19     INFO -      Error: expected 0 to equal 0
14:57:19     INFO -          at chaiAssert (http://test-agent.gaiamobile.org:8080/common/test/helper.js:30)
14:57:19     INFO -          at notEqual (http://test-agent.gaiamobile.org:8080/common/vendor/chai/chai.js:1276)
14:57:19     INFO -          at (anonymous) (http://homescreen.gaiamobile.org:8080/test/unit/dock_test.js:118)
14:57:19     INFO -          at wrapper (http://test-agent.gaiamobile.org:8080/common/test/mocha_generators.js:62)
14:57:19     INFO -          at run (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3709)
14:57:19     INFO -          at runTest (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:4081)
14:57:19     INFO -          at (anonymous) (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:4127)
14:57:19     INFO -          at next (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:4007)
14:57:19     INFO -          at (anonymous) (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:4016)
14:57:19     INFO -          at next (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3964)
14:57:19     INFO -          at (anonymous) (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3979)
14:57:19     INFO -          at done (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3700)
14:57:19     INFO -          at (anonymous) (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3712)
14:57:19     INFO -          at (anonymous) (http://test-agent.gaiamobile.org:8080/common/test/mocha_generators.js:46)
14:57:19     INFO -          at (anonymous) (http://homescreen.gaiamobile.org:8080/test/unit/dock_test.js:105)
14:57:19     INFO -          at wrapper (http://test-agent.gaiamobile.org:8080/common/test/mocha_generators.js:60)
14:57:19     INFO -          at run (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3709)
14:57:19     INFO -          at next (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3973)
14:57:19     INFO -          at (anonymous) (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3984)
14:57:19     INFO -          at (anonymous) (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:4932)

Full log:

https://tbpl.mozilla.org/php/getParsedLog.php?id=22568249&tree=Cedar&full=1#error7
Hi Christian, are you the right person to look into this failure? Who knows the dock code?
Flags: needinfo?(crdlc)
(Assignee)

Comment 2

5 years ago
OK, I can take a look, thanks
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Flags: needinfo?(crdlc)
(Assignee)

Comment 3

5 years ago
Created attachment 753150 [details]
Patch v1

I was not able to reproduce this bug in my laptop running make test-agent-test. Although I saw something what could fire a unexpected fail. Maybe, it will fix the bug, please, if the bug is still reproducible, re-open it. Just added a log in order to have more info if the bug still present. Thanks
Attachment #753150 - Flags: review?(jmcf)

Updated

5 years ago
Attachment #753150 - Flags: review?(jmcf) → review+
(Assignee)

Comment 4

5 years ago
https://github.com/mozilla-b2g/gaia/commit/c945fb5d41ed5a9c8c35ca30bb8527b912f93c04
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.