If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Calendar] In the day view, 12 PM is wrongly written as 12 AM

RESOLVED FIXED

Status

Firefox OS
Gaia::Calendar
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: gaye, Assigned: gaye)

Tracking

unspecified
x86_64
Linux
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Repro:

1. Launch calendar.
2. Click on the day view.
3. Scroll to 11 AM.
4. Scroll down one hour.
(Assignee)

Updated

4 years ago
QA Contact: gaye
(Assignee)

Updated

4 years ago
Assignee: nobody → gaye
(Assignee)

Comment 1

4 years ago
Created attachment 745437 [details]
Pull request
(Assignee)

Updated

4 years ago
blocking-b2g: --- → leo?
(Assignee)

Updated

4 years ago
Attachment #745437 - Flags: review?(kaze)

Updated

4 years ago
QA Contact: gaye
(Assignee)

Updated

4 years ago
Attachment #745437 - Attachment mime type: text/plain → text/html
(Assignee)

Comment 2

4 years ago
Comment on attachment 745437 [details]
Pull request

<html>
<head>
<meta http-equiv="refresh" content="0; url=https://github.com/mozilla-b2g/gaia/pull/9574">
</head>
<body>
</body>
</html>
Comment on attachment 745437 [details]
Pull request

Expected behavior:

  +---------+------------+
  |    24h  |    12h     |
  +---------+------------+
  |  00:00  |  12:00 PM  |
  |  01:00  |  01:00 AM  |
  |  02:00  |  02:00 AM  |
  |  03:00  |  03:00 AM  |
  |  04:00  |  04:00 AM  |
  |  05:00  |  05:00 AM  |
  |  06:00  |  06:00 AM  |
  |  07:00  |  07:00 AM  |
  |  08:00  |  08:00 AM  |
  |  09:00  |  09:00 AM  |
  |  10:00  |  10:00 AM  |
  |  11:00  |  11:00 AM  |
  |  12:00  |  12:00 PM  |
  |  13:00  |  01:00 PM  |
  |  14:00  |  02:00 PM  |
  |  15:00  |  03:00 PM  |
  |  16:00  |  04:00 PM  |
  |  17:00  |  05:00 PM  |
  |  18:00  |  06:00 PM  |
  |  19:00  |  07:00 PM  |
  |  20:00  |  08:00 PM  |
  |  21:00  |  09:00 PM  |
  |  22:00  |  10:00 PM  |
  |  23:00  |  11:00 PM  |
  +---------+------------+

With my Unagi (Gaia-213d1527), everything works fine in the Settings app:
 • open the Settings app
 • Date & Time > set the time manually to 12:30 PM
 • back
 • Language > switch to French (to be in 24-hour format)
⇒ as expected, the displayed time is 12:30. Same thing on the homescreen.

Doing the same thing with 12:30 AM gives 0:30 in 24-hour format, both in the Settings and on the homescreen.

However, I confirm there is a bug with the Calendar app.

This lets me think that the problem is specific to the Calendar app, and should be fixed in the Calendar app — not in a shared library.
Attachment #745437 - Flags: review?(kaze) → review-
(In reply to Fabien Cazenave [:kaze] (AFK till 2013-05-05) from comment #3)
> Comment on attachment 745437 [details]
> Expected behavior:
> 
>   +---------+------------+
>   |    24h  |    12h     |
>   +---------+------------+
>   |  00:00  |  12:00 PM  |
>   |  01:00  |  01:00 AM  |

Ugh. I meant:

  +---------+------------+
  |    24h  |    12h     |
  +---------+------------+
  |  00:00  |  12:00 AM  |
  |  01:00  |  01:00 AM  |
  |    …    |    …   AM  |
  |  11:00  |  11:00 AM  |
  |  12:00  |  12:00 PM  |
  |  13:00  |  01:00 PM  |
  |    …    |    …   PM  |
  |  23:00  |  11:00 PM  |
  +---------+------------+

… which is the current behavior on my device. Sorry for the confusion.
Comment on attachment 745437 [details]
Pull request

Ugh, so sorry for the confusion *again*.

Gaye, you are right and I was wrong. Your patch makes total sense.
Attachment #745437 - Flags: review- → review+
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Keywords: verifyme
QA Contact: jsmith
https://github.com/mozilla-b2g/gaia/commit/472a9d1d2a7494fafbbab3da77793389b73cfa5f

Comment 7

4 years ago
This issue still reproduces on the Leo device:
Leo Build ID: 20130507070204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/884ad1bbe24e
Gaia: 1bac83700810f27e00a937e34e7c865da02e0215
The 12 am time slot appears twice on the Day and Week view of the calendar
Triage: blocking -- small fix for a bad problem
blocking-b2g: leo? → leo+

Updated

4 years ago
Duplicate of this bug: 868762

Updated

4 years ago
status-b2g18: --- → affected
Hi all,

This bug was still happened in the v1-train.
Will we land the patch in the v1-train?

Thanks. :)
Evan - The tree managers will eventually come by an uplift your bug.

Updated

4 years ago
Blocks: 863318
Uplifted 472a9d1d2a7494fafbbab3da77793389b73cfa5f to:
v1-train: 52b28dbf6d053f78d36164d1553a66d40b5d1918
status-b2g18: affected → fixed
Verified on b2g18 on 5/10 build.
status-b2g18: fixed → verified
Keywords: verifyme

Updated

4 years ago
Flags: in-moztrap?

Updated

4 years ago
Flags: in-moztrap? → in-moztrap+

Comment 14

4 years ago
Added Calendar Suite Test Case #8742 - [Calendar] Hours are displayed properly in the Calendar's Day view mode
You need to log in before you can comment on or make changes to this bug.