Since the planned restructuration of Firefox with Australis and that Electrolysis project cuts down many Options/customizations/addons/themes - how about putting old Firefox in Maintenance mode

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: xyz, Unassigned)

Tracking

Trunk
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:20.0) Gecko/20130409 Firefox/20.0 PaleMoon/20.0.1
Build ID: 20130409184116

Steps to reproduce:

Since i do follow Firefox already since V1 and like the amount of Options and Customizations - i see for Future Versions with Australis and that possible Multi-Process restructuring quite some Problems, many stuff will not work anymore and it will be hard to keep the rest under that restructuring process working.


Actual results:

We have right now Firefox in a state of very high customization options, that overflow of options either fits not with planned future Projects or removes Stability in general and affects performance in a negative way too.

Brings for many people conflicts with various addons, full themes, Customization options in general.. which already was written, renders the browser under certain situations useless for some Users. All in all that creates quite a negative Impact.


Expected results:

Perhaps it would be better that instead of stripping Normal Firefox down to go the way like it has be done with Thunderbird. Send Firefox in Maintenance mode, cut down support for Full Themes, remove support for incompatible addons which will not work under that Electrolysis project and limit Customization to the amount that it works with Australis, Electrolysis and possible future Projects.

-Create a new logo
-Create a new Name for the Future Browser

Since that upcoming future plans are in the end a complete restructuring of Firefox for 180° - Many stuff which works at the Stable Release right now will not be available in Future Versions anymore.

Would take away negative impact, the ones who want Full Customization could use the "Legacy Firefox" while all the other people who value stability over Complexity could use that options and functions stripped New Firefox then.
I'm sorry but bugzilla is not the right place for general discussions about the future of Firefox or UI decisions.
Bugzilla is a tool for our developers to manage their work on Firefox and each bug report has to be specific about a single issue. 
The right place for your report would be in the newsgroups/google groups.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.