Last Comment Bug 868747 - Avoid a crash outputting 'resume state' debug 'spew' when compiling asm.js code.
: Avoid a crash outputting 'resume state' debug 'spew' when compiling asm.js code.
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla23
Assigned To: Douglas Crosher [:dougc]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-04 06:20 PDT by Douglas Crosher [:dougc]
Modified: 2013-05-07 19:38 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch to avoid outputting the resume state if there are no resume points. (980 bytes, patch)
2013-05-04 06:23 PDT, Douglas Crosher [:dougc]
luke: review+
Details | Diff | Review

Description Douglas Crosher [:dougc] 2013-05-04 06:20:00 PDT
When compiling asm.js code and with the debug 'spew' enabled, a SIGSEGV occurs trying to output the resume state in SpewResumePoint because lastResumePoint_ is NULL.
Comment 1 Douglas Crosher [:dougc] 2013-05-04 06:23:25 PDT
Created attachment 745534 [details] [diff] [review]
Patch to avoid outputting the resume state if there are no resume points.
Comment 2 Ryan VanderMeulen [:RyanVM] 2013-05-06 19:03:06 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/4a42bd9ee712
Comment 3 Ryan VanderMeulen [:RyanVM] 2013-05-07 19:38:59 PDT
https://hg.mozilla.org/mozilla-central/rev/4a42bd9ee712

Note You need to log in before you can comment on or make changes to this bug.