Spell checker crashing - null PersonalDbFile pointer

VERIFIED FIXED in M11

Status

()

Core
Editor
P3
normal
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: Charles Manske, Assigned: kinmoz)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Just click on the "Spell" toolbar button.
Here's the stack:
strncpy() line 164
CSpellChecker::Initialize(CSpellChecker * const 0x02690510, int 106, int 4112,
char * 0x026906e8, char * 0x00000000) line 543 + 28 bytes
nsSpellCheckGlue::InitSpellChecker() line 469 + 44 bytes
nsSpellCheckGlue::nsSpellCheckGlue() line 58 + 8 bytes
nsSpellCheckGlueFactory::CreateInstance(nsSpellCheckGlueFactory * const
0x02690490, nsISupports * 0x00000000, const nsID & {...}, void * * 0x0266f780)
line 96 + 27 bytes
nsComponentManagerImpl::CreateInstance(nsComponentManagerImpl * const
0x012442b0, const nsID & {...}, nsISupports * 0x00000000, const nsID & {...},
void * * 0x0266f780) line 1126 + 24 bytes
nsComponentManager::CreateInstance(const nsID & {...}, nsISupports * 0x00000000,
const nsID & {...}, void * * 0x0266f780) line 68
nsEditorShell::StartSpellChecking(nsEditorShell * const 0x0266f774, unsigned
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M8
(Assignee)

Comment 1

19 years ago
Accepting bug. Setting target milestone to M8.

Charlie, I can't reproduce this with my build from today at all. Things work
just fine. I'll try a fresh pull tomorrow and see if I can reproduce the crash.
(Assignee)

Comment 2

19 years ago
FYI We narrowed this down to something in Charlie's build environment. One of
the libraries, xpcom I believe, that the spellchecker library is linking against
is bad.
(Assignee)

Updated

19 years ago
Target Milestone: M8 → M9
(Assignee)

Comment 3

19 years ago
Moving to M9.
(Assignee)

Comment 4

19 years ago
Moving all spellchecker/text services related bugs to M11 since I will still be
working on AutoComplete features through M10.
(Assignee)

Comment 5

19 years ago
Charlie, can we close this bug? I think we figured out that your _MSC_VER
environment variable was set incorrectly.
(Reporter)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

19 years ago
Yep.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 7

19 years ago
verified in 9/9 build.
You need to log in before you can comment on or make changes to this bug.