[Buri][IOT]Does not send messages to destinations of 8 digits

RESOLVED FIXED in 1.0.1 IOT1 (10may)

Status

()

Core
DOM: Device Interfaces
P1
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: sync-1, Assigned: Anshul, NeedInfo)

Tracking

(Blocks: 1 bug)

unspecified
1.0.1 IOT1 (10may)
ARM
Gonk (Firefox OS)
Points:
---
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18+)

Details

(Whiteboard: [status: awaiting logs from reporter, potential NPOTB] Chile, IOT, Buri, RIL-Track,)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.092
 Firefox os  v1.0.1
 Mozilla build ID:20130430070201
 
 +++ This bug was initially created as a clone of Bug #449422 +++
 
 DEFECT DESCRIPTION:
 Does not send messages to destinations of 8 digits.
 The DuT add to +56 to the number of 8 digits (i.e +5612345678), the message is not send.
 However, if to the number of 8 digits adds the digit number 9 (i.e +56912345678), the message is sent. 
 
  REPRODUCING PROCEDURES:
 1. Go to messages
 2. Create a new message
 3. Insert a valid number of 8 digits in the field "TO"
 4. Send the message
 5. Check the behavior
  
 
  EXPECTED BEHAVIOUR:
 The DuT should to send the message with 8 digits (i.e 12345678).
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 sw127 + YJ127NV0
 
  USER IMPACT:
 High
 
  REPRODUCING RATE:
 100%
 
  For FT PR, Please list reference mobile's behavior:
 
 ++++++++++ end of initial bug #449422 description ++++++++++

Updated

5 years ago
blocking-b2g: --- → tef?
(Assignee)

Comment 1

5 years ago
Amelie, please provide android main logs and the radio logs.
 adb logcat -b radio -b main -v time
(Assignee)

Updated

5 years ago
Assignee: nobody → anshulj

Updated

5 years ago
Summary: [Buri][HOMO]Does not send messages to destinations of 8 digits → [Buri][IOT]Does not send messages to destinations of 8 digits
Hi, 

We should wait until carrier priorization until nominating this issue, but IMO this will not be a blocking one. 

Thks!
David
triage: tef- per comment from TEF and set tracking-b2g18+
blocking-b2g: tef? → -
tracking-b2g18: --- → +
Hi, 

Sorry, but finally this issue is required by Venezuela. 

renominated to tef?
blocking-b2g: - → tef?

Updated

5 years ago
blocking-b2g: tef? → tef+
(Assignee)

Comment 5

5 years ago
I am still waiting for logs as per my comment #1.
Should this be marked POVB or NPOTB?
Flags: needinfo?(sync-1)
Flags: needinfo?(mei.kong)
Whiteboard: [status: awaiting logs from reporter, potential NPOTB]

Comment 7

5 years ago
Dear,

In Colombia, Venezuela y Mexico this scenary is not  possible to reproduce. So
we ask to Chile.
When we have the logs, I will send you ASAP.

Thanks for understand
Flags: needinfo?(sync-1)
Flags: needinfo?(mei.kong)
bugs tef+ from IOT#1 automatically milestoned for May 10th to be included in IOT#2 testing. Understand the schedule is tight, if not able to make it, please raise. Thanks
Target Milestone: --- → 1.0.1 IOT1 (10may)
(Assignee)

Updated

5 years ago
Assignee: anshulj → mschwart
Whiteboard: [status: awaiting logs from reporter, potential NPOTB] → [status: awaiting logs from reporter, potential NPOTB] Chile, IOT, Buri
any further update on the logs? thanks
Flags: needinfo?(mei.kong)
(Assignee)

Updated

5 years ago
Assignee: mschwart → pgravel
(Assignee)

Comment 10

5 years ago
This is a TEF+ issue and I haven't seen any logs yet. Please provide the logs if this is still a TEF+ issue.
Flags: needinfo?(sync-1)
this should be leo+ (not tef+) as affected markets are only leo markets.
blocking-b2g: tef+ → leo?
Triage - Leo+ per comment 11, IOT issue in target market.
blocking-b2g: leo? → leo+

Updated

5 years ago
Whiteboard: [status: awaiting logs from reporter, potential NPOTB] Chile, IOT, Buri → [status: awaiting logs from reporter, potential NPOTB] Chile, IOT, Buri, RIL-Track,

Comment 13

5 years ago
Created attachment 755755 [details]
Hi, Anshul, please,check!

We can only reproduce this issue in Chile( ok in Mexico/Colombia/Venezuela ).
Can you help to analyze the root cause of the sms failure in 8 bits? 

Another adb log will uploader later when vali sends me.
Flags: needinfo?(sync-1)
Flags: needinfo?(mei.kong)

Comment 14

5 years ago
.isf file provides no useful information. Waiting on adb logs to further debug this issue, as per comment 13.
Flags: needinfo?(sync-1)
(Reporter)

Comment 15

5 years ago
Comment from Mozilla:.isf file provides no useful information. Waiting on adb logs to further debug this issue, as per comment 13.

Comment 16

5 years ago
Created attachment 756325 [details]
Hi Anshul, please check the radio log.
(Reporter)

Comment 17

5 years ago
Comment from Mozilla:HASH(0x9743fd4)

Comment 18

5 years ago
Created attachment 756327 [details]
Hi, Anshul, please check.

According to the analysis of our one engineer:
The SMS are normally sent with and without the +56 prefix, but due to numbering
plan in Chile, if the +56 prefix is added and and extra 9 is not added before
the number, the message will never reach its final destination. 

Normally user can always send SMS to 8 digits numbers XXXXXXXX without prefix
without any issues, but due to the current Chile numbering plan if user wants
to use the +56 prefix, it shall use the following format for mobile numbers:
+56-9-XXXXXXXX ==> Normally user does this manually, so please REMOVE THE AUTO
ADD OF +56 PREFIX AND ISSUE SHALL BE SOLVED.

Thus what do you think about it?
Flags: needinfo?(sync-1)
(Reporter)

Comment 19

5 years ago
Comment from Mozilla:According to the analysis of our one engineer:
 The SMS are normally sent with and without the +56 prefix, but due to numbering
 plan in Chile, if the +56 prefix is added and and extra 9 is not added before
 the number, the message will never reach its final destination. 
 
 Normally user can always send SMS to 8 digits numbers XXXXXXXX without prefix
 without any issues, but due to the current Chile numbering plan if user wants
 to use the +56 prefix, it shall use the following format for mobile numbers:
 +56-9-XXXXXXXX ==> Normally user does this manually, so please REMOVE THE AUTO
 ADD OF +56 PREFIX AND ISSUE SHALL BE SOLVED.
 
 Thus what do you think about it?
Component: Gaia::SMS → DOM: Device Interfaces
Product: Boot2Gecko → Core
(Assignee)

Comment 20

5 years ago
Please provide android main logs and the radio logs as the attached logs aren't useful.
 adb logcat -b radio -b main -v time
Flags: needinfo?(tianm)

Comment 21

5 years ago
(In reply to Anshul from comment #20)
> Please provide android main logs and the radio logs as the attached logs
> aren't useful.
>  adb logcat -b radio -b main -v time

But how can I get that kind of log? I attached the second log gotten by this way.Can you give me a detail description?
Flags: needinfo?(tianm)
(Assignee)

Comment 22

5 years ago
Tianm, sorry I overlooked the logs you specified in the comment #18. I can reproduce the issue and working on fixing it. Will keep you updated.
Assignee: pgravel → anshulj
(Assignee)

Comment 23

5 years ago
The fix for this issue would be available in AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.127 and later. Please verify with this AU once available which would be available in a day or two.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Flags: in-moztrap?

Updated

5 years ago
Flags: in-moztrap? → in-moztrap?(cschmoeckel)

Comment 24

5 years ago
In MozTrap added SMS/Messages Suite Test Case #9003 - Verify that the device can successfully send SMS messages to a destination of 8 digits
Flags: in-moztrap?(cschmoeckel) → in-moztrap+

Comment 25

4 years ago
Hi CSchmoeckel,

Is sending sms to 8 digits nubmer a hard requirement for all products? Or is this only for certain partners? I tried on v1.2 Unagi and Wasabi(CDMA) phone, they can't send SMS to 8 digit number.
Flags: needinfo?(cschmoeckel)
You need to log in before you can comment on or make changes to this bug.