[Buri][IOT][USB disk] Mass storage option must be enable as default.

RESOLVED WONTFIX

Status

P1
normal
RESOLVED WONTFIX
6 years ago
3 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: IOT, Chile, Buri)

(Reporter)

Description

6 years ago
SW126
 AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.085
 Firefox os  v1.0.1
 Mozilla build ID:20130422230201
 
 +++ This bug was initially created as a clone of Bug #449354 +++
 
 DEFECT DESCRIPTION:
 When you plug the USB with PC, it only charges, end user must go to "Settings -> Multimedia ->" and enable USB mode to be detected as a Mass Storage device.
 This kind of settings must be enable as default, due to END USER wont know how to do it.
 
 
  REPRODUCING PROCEDURES:
 1. Plug FF to PC via USB.
 2. Notice it is not recognized as a mass storage device. KO
 
 
  EXPECTED BEHAVIOUR:
 USB mode variable must be enable as default.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
 
 ++++++++++ end of initial bug #449354 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:

Comment 1

6 years ago
Dear, 
We can fix it by change "ums.enabled" to true in gaia/build/settings.py, shall
we fixed it?
Why or why not?
Flags: needinfo?(kkuo)

Comment 2

6 years ago
Hi,
Shall we fix it? Why or why not? Thanks!
Flags: needinfo?(swu)

Comment 3

6 years ago
We should not fix it.

Enabling USB mass storage prevents Gaia apps from accessing memory card when USB cable plugged.  It means you are not able to use Gallery app when you connected USB cable for charging only.

We should only enable it when user really wants to access USB storage from PC.
Flags: needinfo?(swu)
Flags: needinfo?(kkuo)

Comment 4

6 years ago
(In reply to Shian-Yow Wu from comment #3)
> We should not fix it.
> 
> Enabling USB mass storage prevents Gaia apps from accessing memory card when
> USB cable plugged.  It means you are not able to use Gallery app when you
> connected USB cable for charging only.
> 
> We should only enable it when user really wants to access USB storage from
> PC.

agree with the assessment.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX

Comment 5

6 years ago
Another concern is security (per Kanru's comment on IRC).  Anyone would be able to modify the content on the sdcard if it's enabled.

Comment 6

6 years ago
(In reply to Shian-Yow Wu from comment #5)
> Another concern is security (per Kanru's comment on IRC).  Anyone would be
> able to modify the content on the sdcard if it's enabled.

Thank you very much!

Comment 7

6 years ago
As it is IOT issue,I reopen it for triage.
Status: RESOLVED → REOPENED
blocking-b2g: --- → tef?
Resolution: WONTFIX → ---
Summary: [Buri][USB disk] Mass storage option must be enable as default. → [Buri][IOT][USB disk] Mass storage option must be enable as default.
what's the priority on this bug? Amelie?
This seems to be like a new feature, unless David or Beatriz believe this is a cert blocker we should just mark it as tef-
Whiteboard: [tef-triage]
triage: tef-, not blocking. but please consider this for improvement in later release (such as notification to allow user to be aware where to turn on USB mass storage)
blocking-b2g: tef? → koi?
Whiteboard: [tef-triage] → [tef-triage], IOT, Chile, Buri
Whiteboard: [tef-triage], IOT, Chile, Buri → IOT, Chile, Buri
Need UX input for this new behavior (see comment 10)
blocking-b2g: koi? → ---

Updated

3 years ago
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.