Trunk crash installing plugins [@ nsPluginStreamListenerPeer::SetupPluginCacheFile]

VERIFIED DUPLICATE of bug 86774

Status

()

Core
Plug-ins
--
critical
VERIFIED DUPLICATE of bug 86774
17 years ago
8 years ago

People

(Reporter: greer, Assigned: av (gone))

Tracking

({crash, topcrash})

Trunk
x86
Windows NT
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

17 years ago
This one just showed up in the 20010619 builds but it is crashing for a lot of 
users. (Could it have to do with the fix for 83183 checked in on 6/18?) Talkback 
shows it happening on W95, 98 and NT.

nsPluginStreamListenerPeer::SetupPluginCacheFile

     First Appearance Date : 2001-06-19
     Last Appearance Date : 2001-06-20
     First BuildID : 2001061901
     Last BuildID : 2001061911

Stack Trace: 

         nsPluginStreamListenerPeer::SetupPluginCacheFile
[d:\builds\seamonkey\mozilla\modules\plugin\nglsrc\nsPluginHostImpl.cpp  line 
1586]
         nsPluginStreamListenerPeer::OnStartRequest
[d:\builds\seamonkey\mozilla\modules\plugin\nglsrc\nsPluginHostImpl.cpp  line 
1635]
         nsStreamIOChannel::OnStartRequest
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsInputStreamChannel.cpp  line 
453]
         nsOnStartRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp  line 
110]
         PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  
line 591]
         PL_ProcessPendingEvents        
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line
524]
         _md_EventReceiverProc  
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 1072]
         nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp  line 418]
         main1  [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  
line 1146]
         main   [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  
line 1440]
         WinMain        
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1458]
         WinMainCRTStartup()
         KERNEL32.DLL + 0x17d08 (0x77e97d08)
 
        Source File : 
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/modules/plugin/nglsrc/nsPlug
inHostImpl.cpp line
: 1586


     (31928953) Comments: clicked on the "get the plugin" icon for a Java game
     (31923046) URL: http://www.jasc.com/product.asp?pf_id=001
     (31923046) Comments: I tried to download a plug-in from an intranet site.
     (31908864) URL: http://www.shockwave.com/download/completion/index.html
     (31908864) Comments: trying to install shockwave
     (31907564) Comments: I didn't have a plugin
(Reporter)

Comment 1

17 years ago
Adding crash, topcrash for talkback tracking.
Keywords: crash, topcrash

Comment 2

17 years ago
dup of 86774 ?

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 86774 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
v
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsPluginStreamListenerPeer::SetupPluginCacheFile]
You need to log in before you can comment on or make changes to this bug.