WEBGL_depth_texture doesn't work on MacBook Pro Retina

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
5 years ago
4 years ago

People

(Reporter: conor, Unassigned)

Tracking

22 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:22.0) Gecko/20130506 Firefox/22.0
Build ID: 20130506004015

Steps to reproduce:

Go to any site that checks WEBGL extension support, such as http://www.browserleaks.com/webgl

Or write basic WEBGL code to check for WEBGL_depth_texture extension support.


Actual results:

WEBGL_depth_texture is not supported by Firefox when using a MacBook Pro Retina.


Expected results:

WEBGL_depth_texture should be supported. A few versions of Firefox ago it was working and now it is not (sorry, I don't know exactly when it broke, but I think it was around v16 or v17). The extension still works in Chrome.
(Reporter)

Comment 1

4 years ago
Still a problem in Firefox 24.
Could you use mozregression to find the regression range?
(Reporter)

Comment 3

4 years ago
Last good nightly: 2012-12-19
First bad nightly: 2012-12-20
(Reporter)

Comment 4

4 years ago
Turns out this was an intentional blacklisting of MacOS+NVIDIA.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.