If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][Leo][System][Task Manager]: When the user has several apps running (10+) and closes all but one in the task manager, when opening the last app the device will crash.

VERIFIED DUPLICATE of bug 868741

Status

Firefox OS
Gaia::System
VERIFIED DUPLICATE of bug 868741
4 years ago
4 years ago

People

(Reporter: J Zimbrick, Unassigned)

Tracking

({crash, smoketest})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 746122 [details]
Crash screen that is displayed after the crash from the music app.

Description:
  When the user launches 10+ apps and opens the task manager to close all but one, when opening the last app the device will crash.

Repro Steps:

1. Update Leo device to build 20130506070204.
2. Launch the music app and begin playing a song.
3. Return to the homescreen and open several apps. (At least 10 or so.)
4. Hold the home button to open the task manager screen.
5. Close all of the apps except for the music app.
6. With the music app as the last one in the task manager, tap on it to open the music app.
7. Observe that the phone appears to freeze. Music may or may not continue to play and all buttons are unresponsive.  If the user waits long enough a crash screen is displayed. (See attached picture.)

Actual:
 Device crashes when launching the last app.

Expected:
 Device does not crash and the last app is launched properly.

Environmental  Variables:
Kernel Date: Apr 25
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/00c554abfc17
Gaia: 9377636cee5ac55b9f1d68f598afc7aadfbb2b00

Notes:
Repro frequency: Somewhere around the 80% range, seen on 3 different Leo devices.
Q Analysts Test Team Priority: Pri 1
See attached screenshot for more info.

Notes:

The steps provided are just the most consistent way I've found to repro this issue.  Other testers have had it occur without music playing and with a different app as the last one opened.  Potentially a memory issue?
(Reporter)

Comment 1

4 years ago
Also, here's a crash ID from a crash that didn't go to the crash screen shown in the attached screenshot: 261f5da4-3d6d-47f2-b990-1831d2130506

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 868741

Comment 3

4 years ago
verified duplicate as for comment 2, also bug 868741 was resolved fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.