Provide copy for front page CTAs

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: brett, Assigned: erica)

Tracking

Details

(Whiteboard: u=user p=1 s=2013w19)

(Reporter)

Description

5 years ago
We need to review the sections that will need copy writing and start to file the appropriate tickets to have this text written.

Erica, can you find any time tomorrow, May 7th?  Best place to review will be Last page of this document: https://docs.google.com/file/d/0BzfN9sXlOXt1ZEdXYldYTjk3cjA/edit

This will allow Cassie and others to push forward home page this week.
(Reporter)

Updated

5 years ago
Whiteboard: u=user p=1 s=2013w19
(Assignee)

Comment 1

5 years ago
Is there a requirements doc we could work off of? Or something that Cassie is working on now?
Flags: needinfo?(cassie)
Flags: needinfo?(brett)
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
Erica, I've been going off of the PRD: http://etherpad.mozilla.org/webmakerv2prd but have made up some content – for instance in the bottom CTAS – that I thought might be useful for relevant. 

The latest homepage designs can be seen here: http://webmakerv2.tumblr.com/post//changes-to-the-webmaker-experience

Whether or not that CTA row actually needs to be a carousel depends on how much inner content we really need to surface on the homepage.

Also, the nav dropdown is still in the works, I'm going to experiment with a few more options this week and be sure to nail down where everything links to.
Flags: needinfo?(cassie)
Flags: needinfo?(brett)
I actually think we're going about this backwards.

Erica, the goal here is to understand how the various landing experiences of Webmaker can be built to support your commnication goals and objectives, so that we can get on the task of organizing whatever writing work needs to be done.

From a webmaker.org product perspective, the CTAs on the main page ought to reinforce the primary user actions: make something, remix something, share something. Secondary CTAs for learning and teaching may exist, but IMO only once those parts of the product are really built out.

Also, based on our conversations last week, we know that we want to push all users towards the global Maker Party description page (which will feature the four related but not identical CTAs consistent with the Global Campaign).

What we need to know is:

 - is there other consistent marketing / messaging you'd like us to use if at all possible when we're designing CTAs

 - are there other requirements for CTAs or content on the "main" webmaker.org page, or the pages we expect to get a lot of pageviews (ie: the page that someone lands on when they click through to see a make that someone shared)
(In reply to Mike Beltzner [:beltzner] from comment #3)
> I actually think we're going about this backwards.
> 
> Erica, the goal here is to understand how the various landing experiences of
> Webmaker can be built to support your commnication goals and objectives, so
> that we can get on the task of organizing whatever writing work needs to be
> done.
> 
> From a webmaker.org product perspective, the CTAs on the main page ought to
> reinforce the primary user actions: make something, remix something, share
> something. Secondary CTAs for learning and teaching may exist, but IMO only
> once those parts of the product are really built out.
> 

I would just add that the purpose of having CTAs is also to surface content that is buried within the site, particularly content that we know our users want, like the teaching kits and information about events or announcements that are getting a lot of buzz (such as the MOOC). I would recommend at least those two, and perhaps to the page outlining our tools, but other than that the last spot or two is open (and if we need more, we need to know asap if this needs to be a carousel).


> Also, based on our conversations last week, we know that we want to push all
> users towards the global Maker Party description page (which will feature
> the four related but not identical CTAs consistent with the Global Campaign).
> 
> What we need to know is:
> 
>  - is there other consistent marketing / messaging you'd like us to use if
> at all possible when we're designing CTAs
> 
>  - are there other requirements for CTAs or content on the "main"
> webmaker.org page, or the pages we expect to get a lot of pageviews (ie: the
> page that someone lands on when they click through to see a make that
> someone shared)

What we need at this stage to literally finish the design and build of the homepage is what exactly this content should be for launch on June 15, including written content (with a word count similar to what is in the design) and image ideas if you have them.

We also need this for any messaging that needs to appear within the grid itself (not just in the CTA spots).
(Assignee)

Comment 5

5 years ago
Thanks guys this sounds good, and makes sense. Matt is going to connect with you while I'm in SF for now (though I'll be back next week).
(Assignee)

Updated

5 years ago
Assignee: erica → matt
Erica/Matt: There is some discussion in bug 868591 as to whether the static content embedded within the grid will even be possible. (If it is possible, it may not be able to be fixed in one position.) Let's plan to rely on the CTAS in the bottom blue strip for all content needs, with fixed content within the grid as a nice-to-have.
* Ok. working on this now.
As discussed, character count for Footer CTAs is as follows:
Title: 16-18 characters, eg. "Maker Party 2013"
Content: 40-45 characters, eg. "Share knowledge with mentors and educators."
@ Cassie: Here's copy for the next iteration of the blue front page CTA carousel:

Tools
Get started with Thimble, Popcorn or the X-Ray Goggles

Skills
Learn new digital and tech skills -- and earn badges that prove it

Guides
Teach digital literacy through fun making and sharing

Party
Now to Sep 15: get together at Maker Party events everywhere

* Made a mock-up so I could visualize those character counts you provided:
https://wiki.mozilla.org/File:Maker_Party_front_page_--_v2.001.jpg
Summary: Review front page for relevant CTAs → Provide copy for front page CTAs
* Here's content for the revised and more robust footer we talked about: 
blog  | tumblr | email | @mozilla  | @webmaker  | facebook | get involved | donate
* Radically de-emphasizing the prominence of the partners logos, as per discussion
* I think having a more robust and useful footer underneath the CTA carousel tells a good story and implies a logical visual relationship 
* Next I'll think more about how CTAs might work in the gallery above
* QUESTION: "claim your URL" is a prominent CTA in the current mock-up
* Brett / Beltzner: can you say more about that? Any context or strategy behind it we should be aware of?
(In reply to Matt Thompson (@OpenMatt) from comment #10)
> * Here's content for the revised and more robust footer we talked about: 
> blog  | tumblr | email | @mozilla  | @webmaker  | facebook | get involved |
> donate
> * Radically de-emphasizing the prominence of the partners logos, as per
> discussion
> * I think having a more robust and useful footer underneath the CTA carousel
> tells a good story and implies a logical visual relationship 
> * Next I'll think more about how CTAs might work in the gallery above

Thank Matt, great. Wherever the logos go (footer or otherwise), I do need to know which ones to display.
(In reply to Matt Thompson (@OpenMatt) from comment #9)
> @ Cassie: Here's copy for the next iteration of the blue front page CTA
> carousel:
> 
> Tools
> Get started with Thimble, Popcorn or the X-Ray Goggles
> 
> Skills
> Learn new digital and tech skills -- and earn badges that prove it
> 
> Guides
> Teach digital literacy through fun making and sharing
> 
> Party
> Now to Sep 15: get together at Maker Party events everywhere
> 
> * Made a mock-up so I could visualize those character counts you provided:
> https://wiki.mozilla.org/File:Maker_Party_front_page_--_v2.001.jpg

Nice mockup :) I think I'll probably increase the height of the blue bar if you need the three lines of text, instead of two. We'll also remove the carousel functionality for now.
* Cool! I'd vote for keeping the carousel functionality still if possible. There are additional CTAs we may want to include -- I just wanted to start by providing the top four
(In reply to Cassie McDaniel [:cassiemc] from comment #12)
> (In reply to Matt Thompson (@OpenMatt) from comment #10)
> > * Here's content for the revised and more robust footer we talked about: 
> > blog  | tumblr | email | @mozilla  | @webmaker  | facebook | get involved |
> > donate
> > * Radically de-emphasizing the prominence of the partners logos, as per
> > discussion
> > * I think having a more robust and useful footer underneath the CTA carousel
> > tells a good story and implies a logical visual relationship 
> > * Next I'll think more about how CTAs might work in the gallery above
> 
> Thank Matt, great. Wherever the logos go (footer or otherwise), I do need to
> know which ones to display.

* Chasing that down for you here: https://bugzilla.mozilla.org/show_bug.cgi?id=870462
* My proposal: don't list them on the front page at all. Move them to /about instead
@ Cassie: i forgot something else we should add to the footer: "About us"
Awesome. This makes we wonder if we should link to privacy or terms and conditions as well... or if it is enough to have that in the registration process.
* Good point. Here's an updated list for the footer, grouped by importance:

P1
blog | about us | get involved | donate

P2
@mozilla  | @webmaker  | facebook | tumblr | email |

P3
contact | privacy | legal
Are "contact" and "email" the same thing? Will "privacy" and "legal" need to live on separate pages?
QUESTION @ Beltzner / Brett / Cassie: does "claiming your url" prompt you to sign-in through Persona?
* if so, does that include an opportunity to grow our list? is BSD integration or opt-in a part of the process?
(In reply to Cassie McDaniel [:cassiemc] from comment #19)
> Are "contact" and "email" the same thing? 

no. 
"email" = "sign up to receive email updates from us" https://sendto.mozilla.org/page/s/webmaker
"contact" = get in touch with us via email. 



Will "privacy" and "legal" need to live on separate pages?

yes. 
privacy = http://www.mozilla.org/en-US/privacy-policy.html
legal = http://www.mozilla.org/en-US/about/legal.html

This is partly why I was trying to tease out which footer elements are high priority for users vs low priority. "contact, legal and privacy" are basically fine print. Whereas "blog" and "about us" is actually useful to many users.
@ Erica: one of the key challenges / opportunities we have for the front page: filling in the blanks for this mock-up: http://mzl.la/147jeEK

CONTEXT:
* "Joining" Webmaker. What's nice about this in Cassie's current mock-up: it implies a natural, compelling reason to "join" by claiming your own little piece of Webmaker: "webmaker.org/your_name_here" 
* e.g., "webmaker.org/OpenMatt" or "webmaker.org/EricaS" (actual URL will vary, but you get the idea)
* This is a bit like claiming a gmail address, or Twitter handle, or useful piece of real estate on the web. With "join" baked in -- instead of just forking over your email address for no reason.
* investigating now how that can integrate with email capture for list-building purposes
* looking for the best way to write around this idea. As per the mock-up: http://mzl.la/147jeEK
Flags: needinfo?(mbeltzner)
Depends on: 870509
Matt: How's this? http://cl.ly/Oqha

The two footers here show what the exposed functionality of the signup form could be. So a user clicks into the field to put in their email address and the overlay with the signup terms comes up; would disappear if user clicks outside of the box. If you like, I can design error messages too.

I realize you may want to call out other links a little more, like About / Get Involved / Donate, but this is about what I want in terms of simplicity. Two lines is better than 3, imo, esp. since we have the CTAs in the blue bar above. It gets overwhelming rather quickly so any logical grouping is ideal.
* Looks great!
* Correct opt-in language for this instance is: "I’m okay with you handling this info as you explain in your [privacy policy]."
* Although I *might* beg you to make the second line a little more prominent, even if just making the text a bit bigger...
@ Erica: here's me and Cassie's current favorite proposal for front page copy: http://mzl.la/11WolWC
* Plus a PDF with a dozen other options: http://mzl.la/11Wos4x
* Still need to work in the community / movement element more.
* Cassie and I have taken this as far as we can for now
* Assigning to Erica for review
* Needinfo from Brett or Beltzner to think through how "claim" fits into our email capture and engagement ladder
Assignee: matt → erica
I actually think we should call this closed, implement the copy as designed, and then if we need to make changes we can open up separate bugs. Everyone OK with that?

Also, see bug 870509 for the resolution on the "claim" issue.

Cassie: please go ahead and use the copy from here in the designs that you're handing off to be implemented.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(mbeltzner)
Resolution: --- → FIXED
Sounds good to me.
sounds good
Component: Marketing → General
Product: Webmaker → Webmaker
You need to log in before you can comment on or make changes to this bug.