[Homescreen] When pressing the app icon continuosly in homescreen, the app is launched twice.

RESOLVED FIXED in 1.1 QE2 (6jun)

Status

Firefox OS
Gaia::Homescreen
P2
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Leo, Assigned: crdlc)

Tracking

unspecified
1.1 QE2 (6jun)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ fixed)

Details

(Whiteboard: [TD-23615])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
1. Title : When pressing the app icon continuosly in homescreen, the app is launched twice. 
2. Precondition : 
3. Tester's Action : Launch Home Screen -> Click the app icon continuosly
4. Detailed Symptom (ENG.) : the app is launched and come to homescreen. Then relaunch the app. 
5. Expected :The app is launched in first touch, then second touch is received by the launched app. 
6.Reproducibility: Y
	1)Frequency Rate : 100%
7.Gaia Master/v1-train : Reproduced
8.Gaia Revision: 8560da0c79b293cb421e33dc9b99f2afc12b6fdf
9.Personal email id:  jjoons79@gmail.com
(Reporter)

Comment 1

5 years ago
Created attachment 746231 [details]
Attach the video
(Assignee)

Comment 2

5 years ago
Here there are two possibilities:

1) System app should control the launching apps better (Component Gaia::System)
2) Homescreen should deal continuos clicks event on an app (Component Gaia::Homescreen)

IMHO this bug can be resolved in the homescreen side because the risk is null here with only a few lines of code, fir example a quick idea could be:

// After launch app...
icon.disabled = true;
setTimeout(function() {
   icon.disabled = false;
}, TIMEOUT_TO_BE_DEFINED);

What do you think Vivien?
Flags: needinfo?(21)
Hi Leo, Cristian,

Triage would like to know if the app is actually launched twice of if it's just seemingly being launched multiple times i.e. while launching the focus is toggled between home and the app.

If the app is actually launched twice, can this be seen by the user in card view and are there any functional impacts?
Flags: needinfo?(leo.bugzilla.gaia)
Flags: needinfo?(crdlc)
(Assignee)

Comment 4

5 years ago
Umm, at least in my Unagi, they aren't launched multiple times because there is only one instance running in the task switcher
Flags: needinfo?(crdlc)

Comment 5

5 years ago
Please renominate if this is still critical for you (only one app is launched, it's just UX polish), and you're willing to assign this bug to yourself.
blocking-b2g: leo? → -

Updated

5 years ago
tracking-b2g18: --- → +
(Assignee)

Comment 6

5 years ago
You are right, only one app is launched although users think that several apps are launched at the same time and it is incoherent. The patch will be easy and the risk closed to null. Maybe, are you comfortable if I implement a patch and after that I ask for approval v1? Thanks a lot
Flags: needinfo?(akeybl)

Updated

5 years ago
Target Milestone: --- → 1.1 QE2

Comment 7

5 years ago
(In reply to Cristian Rodriguez de la Cruz (:crdlc) from comment #6)
> You are right, only one app is launched although users think that several
> apps are launched at the same time and it is incoherent. The patch will be
> easy and the risk closed to null. Maybe, are you comfortable if I implement
> a patch and after that I ask for approval v1? Thanks a lot

Yes we're OK with that.
Flags: needinfo?(akeybl)
(Assignee)

Comment 8

5 years ago
Created attachment 749722 [details]
Patch v1
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Attachment #749722 - Flags: review?(francisco.jordano)
Flags: needinfo?(leo.bugzilla.gaia)
Flags: needinfo?(21)
Hi folks,

I've been checking and trying the patch and the resolution is quite clean and understandable, but during the app launch we do a zoom on the desktop, making the icons change position, so if we try to perform a second tap quite quickly we won't be able to click on the icon that we already clicked, but could click on any other icon that during the zoom animation takes the position of the old icon.

Commented with Cristian this, and he commented me to making the same but for all icons not just the one just tapped, which sounds like a good idea.

Cheers,
F.
(Assignee)

Comment 10

5 years ago
perfect, great suggestion, implementing right now
(Assignee)

Comment 11

5 years ago
it makes sense completely. I have implemented the suggestion, thanks Fran!
Comment on attachment 749722 [details]
Patch v1

Looking perfect and clean to me,

thanks a lot Cristian!
Attachment #749722 - Flags: review?(francisco.jordano) → review+
(Assignee)

Comment 13

5 years ago
https://github.com/mozilla-b2g/gaia/pull/9787
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 14

5 years ago
Comment on attachment 749722 [details]
Patch v1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: see video attached in the bug
Testing completed: yes
Risk to taking this patch (and alternatives if risky): close to null
String or UUID changes made by this patch:
Attachment #749722 - Flags: approval-gaia-v1?

Updated

5 years ago
Attachment #749722 - Flags: approval-gaia-v1? → approval-gaia-v1+
Cristian,

In the future please mirror git shas to bugzilla so they're easier to find for uplift :).

Landed in master: 758e3f03da31695a37ce5d5beddf3d4ae0e9f0c5
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 758e3f03da31695a37ce5d5beddf3d4ae0e9f0c5
  <RESOLVE MERGE CONFLICTS>
  git commit
(Assignee)

Comment 17

5 years ago
Uppsss in comment 13 I wanted to add the commit's hash but I was wrong and added a link to an unrelated pull, sorry
(Assignee)

Comment 18

5 years ago
v1-train: 2b0920791a556610123b0f274e13876684de253a

master: ec6e4178f3227f6adac6191855072a89b6bbc6a6 (the hast in comment 15 is wrong)
(Assignee)

Updated

5 years ago
status-b2g18: --- → fixed
You need to log in before you can comment on or make changes to this bug.