If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

No way to fix mistyped URLs

RESOLVED DUPLICATE of bug 671233

Status

()

Firefox
Search
--
enhancement
RESOLVED DUPLICATE of bug 671233
4 years ago
4 years ago

People

(Reporter: Dan Jacobson, Unassigned)

Tracking

22 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:22.0) Gecko/20130426 Firefox/22.0 Iceweasel/22.0a2
Build ID: 20130426004017

Steps to reproduce:

Entered
+http://example.com/some/very/long/url/which/we/would/not/like/to/type/again/all/over
into the URL bar and hit ENTER.
Note the accidental "+".


Actual results:

Was sent to Google with no way to clean up my mistake by removing that little "+",
as the URL bar has now become full of "%"s and the BACK button has no where to go BACK to.
One can at best dig the URL out of the Google page and paste it back into the URL bar.


Expected results:

There should be a way to clean it up via Firefox and not needing to dig it back out of the Google page.
(Reporter)

Comment 1

4 years ago
Yes, Adblock Plus can protect one in this case. But I am saying Firefox needs to give a way to fix things!
Hello, since this is an enhancement request I'm changing the appropriate field accordingly.
However this behaviour is also reproducible on Windows 7, x64, with Firefox 20.0.1, Aurora 22.0, and Nightly 23.0. 

- User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0, Build ID: 20130409194949.

- User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130509 Firefox/22.0, Build ID: 20130509004018.

- User agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:23.0) Gecko/20130509 Firefox/23.0, Build ID: 20130509031047.

If it can help you, in this particular case (a plus sign before the url) you can see that after "https://www.google.it/search?q=" there is a "%2B" which is the plus. You can just remove it.
Also, if you're redirected to the Google search results page you can fix the url from the Google search bar on the top of the page. Obviously this isn't the same thing as going straight to the website you wanted, but it's a workaround you can do in the meantime :)

If you have suggestions on how the developers could make it easier to fix a mistyped url, please share them in a comment.
Thank you!
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Component: Untriaged → Search
Ever confirmed: true
OS: Linux → All
Hardware: x86 → All
Sorry, didn't see it's a duplicate.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 671233
(Reporter)

Comment 4

4 years ago
Not only the + gets encoded, but a lot more,
https://www.google.com/search?q=%2Bhttp%3A%2F%2Fexample.com%2Fsome%2Fvery%2Flong%2Furl%2Fwhich%2Fwe%2Fwould%2Fnot%2Flike%2Fto%2Ftype%2Fagain%2Fall%2Fover&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:unofficial&client=iceweasel-a&channel=fflb
making one have to turn to digging it back of the textbox on the Google page, yes.
You need to log in before you can comment on or make changes to this bug.