Closing msg compose window crashes (Linux)

VERIFIED WORKSFORME

Status

--
critical
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: leif, Assigned: vparthas)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I pulled the latest source this morning, and did a dep build. Now closing
message compose windows crashes (on Linux). To reproduce, I do

1. Start mozilla.

2. Open a compose window (CTRL-m)

3. Close compose window (CTRL-w, if focus works)

4. It crashes, with

ComposeUnload from XUL
Gdk-ERROR **: BadWindow (invalid Window parameter)
  serial 7800 error_code 3 request_code 15 minor_code 0


I'm doing a clobber rebuild right now, and will post more to this bug if I find
anything interesting.

-- Leif
varada, can you investigate this crasher?
Assignee: sspitzer → varada
Component: Mail Window Front End → Composition

Updated

17 years ago
Keywords: crash
(Assignee)

Comment 2

17 years ago
investigating this crasher
(Assignee)

Comment 3

17 years ago
When I follow the steps - I see a JS exception in the console but there is no
crash. The exception is JS Error"setting a property that has only a getter". If
I dont enter anything in the window I get this when at the
msgCompose.CloseWindow() line else if I have entered something and I get the
save as dialog and I say yes I get the error at the msgCompose.bodyModified
line. In either case it is with the msgCompose object.
Still looking into it.
(Reporter)

Comment 4

17 years ago
I just did a clobber build, after pulling the latest source. This bug still
happens, as outlined earlier. Error I get is still:

ComposeUnload from XUL
Gdk-ERROR **: BadWindow (invalid Window parameter)
  serial 8514 error_code 3 request_code 4 minor_code 0
Gdk-ERROR **: BadWindow (invalid Window parameter)
  serial 8515 error_code 3 request_code 4 minor_code 0

Maybe it's something with my GTK installation? I'm running Mandrake 7.2 on this
machine. I can't say for sure, but I don't recall seeing this before.

Thanks,

-- Leif
I don't see this either.  (I'm on RH 6.0)

leif, can you get a stack trace?

do you have any changes in your tree for LDAP autocomplete or any LDAP
autocomplete prefs enabled that perhaps varada and I don't have?
(Reporter)

Comment 6

17 years ago
I have some more data on this. I was wrong, the machine that this crashes on is
a Mandrake 8.0 system. I just tested the same thing on a Mandrake 7.2, and it
works fine there.

On the 7.2 system I have these libraries installed:

gtk+-1.2.8-6mdk_helix_1
gtk+-devel-1.2.8-6mdk_helix_1

while on the 8.0 system I have

libgtk+1.2-1.2.10-1mdk
libgtk+1.2-devel-1.2.10-1mdk

I believe the latter means it's v1.2.10 of GTK.

Unfortunately neither of these two systems are happy with GDB (even the latest
CVS gdb), maybe because they are both SMP machines (dual CPUs). I'm gonna try to
install Mandrake 8.0 on a crappy laptop I got, which is single CPU, and hope to
debug there.

Thanks,

-- Leif

Comment 7

17 years ago
WFM. current linux CVS, RH7.1

Comment 8

17 years ago
WFM, 2001-11-02 build, RH 6.2

Comment 9

17 years ago
No word from reporter for nearly 7 months.
Reporter: Are you still seeing this crash?
(Still WFM, current linux CVS)
(Reporter)

Comment 10

17 years ago
No, close this bug please.

Comment 11

17 years ago
per reporters comment
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.