If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[customize]Can't open homescreen with firefox nightly profile while make with HIDPI=1

RESOLVED FIXED

Status

Firefox OS
General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: gasolin, Assigned: gasolin)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Assignee)

Description

4 years ago
while make with 

 $ HIDPI=1 DEBUG=1 make

and start firefox nightly with 

 $ /Application/firefox -profile /user_path/gaia/profile

Homescreen can not be opened as usual.
(Assignee)

Updated

4 years ago
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → Other
(Assignee)

Comment 1

4 years ago
I found in Makefile:'profile/settings.json' section

It run python build/settings.py twice to generate settings.json

I think the first one is redundant.
Is there any particular reason to do that?
Flags: needinfo?(yurenju.mozilla)
(Assignee)

Updated

4 years ago
Assignee: nobody → gasolin
(Assignee)

Updated

4 years ago
Flags: needinfo?(yurenju.mozilla)
Summary: Can't open homescreen with firefox nightly profile while make with HIDPI=1 → [customize]Can't open homescreen with firefox nightly profile while make with HIDPI=1
(Assignee)

Comment 2

4 years ago
Created attachment 749677 [details]
pull request redirect to github

The --hidpi not pass param to settings.py, which cause weird result that can't be parsed correctly.

remove it because pass correspondent --wallpaper to settings.py is sufficient to do the HIDPI work in settings.py
Attachment #749677 - Flags: review?(timdream)
Attachment #749677 - Flags: review?(timdream) → review+
(Assignee)

Comment 3

4 years ago
merged to master-gaia c51c8b38558fd82216ef8220368bd63cefc50322
thanks!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
It seems that the root cause is that there is an extra ":" before $(GAIA_PORT)?

==
ifeq ($(DEBUG),1)
  SETTINGS_ARG += --homescreen=http://homescreen.$(GAIA_DOMAIN):$(GAIA_PORT)/manifest.webapp
endif
==

This issue would only occur when trying to run the following line, because "--homescreen" would be regarded as the parameter for "--hidpi", which will not override the settings in $(SETTINGS_ARG).

"python build/settings.py $(SETTINGS_ARG) --hidpi --homescreen $(SCHEME)homescreen.$(GAIA_DOMAIN)$(GAIA_PORT)/manifest.webapp"
(Assignee)

Comment 5

4 years ago
I think remove ':' as $(GAIA_DOMAIN)$(GAIA_PORT) will lead to address like 'http://192.168.1.18080' instead of 'http://192.168.1.1:8080', which is not the correct URL
However, the default for GAIA_PORT is defined with ":",
GAIA_PORT?=:8080

That's why we got an extra ":" here, i.e.,
  SETTINGS_ARG += --homescreen=http://homescreen..gaiamobile.org::8080/manifest.webapp

Thanks.
(Assignee)

Comment 7

4 years ago
Rudy, Nice catch! 
Though the current patch works and it might not worth to fire another issue to solve that independently.

needinfo? kevin, would you mind give a favor to remove ':'$(GAIA_PORT) described in comment 6 while you do other desktop-helper change?
Flags: needinfo?(kevingrandon)
(Assignee)

Comment 8

4 years ago
nominate to upport preview screen in nightly
need uplift this patch to HD branch
blocking-b2g: --- → hd?
Flags: needinfo?(kevingrandon)
Created attachment 765190 [details]
Github pull request pointer

I was curious so was poking around. Not sure if you still need this, but here's a pull request anyway.
Attachment #765190 - Flags: review?(gasolin)
Created attachment 765193 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10497

Pointer to Github pull-request
(Assignee)

Comment 11

4 years ago
Comment on attachment 765190 [details]
Github pull request pointer

kevin thanks for the favor, 
originally I'd expect its a minor issue that not need to fix independently.
Attachment #765190 - Flags: review?(gasolin) → review+
True, but I'm sure we would've forgotten about it :)

Landed in master here: https://github.com/mozilla-b2g/gaia/commit/dbc7647607166ae731c55a7d4c2bc878e0dfb231
(Assignee)

Comment 13

4 years ago
Just check v1.1.0hd Makefile, it has changed to GAIA_DEV_PIXELS_PER_PX base, so its not relevant to this issue though
blocking-b2g: hd? → ---
You need to log in before you can comment on or make changes to this bug.