[ikura/inari] [Facebook] Offline experience is different if you have used the app with connection previously

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Homescreen
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: carlosmartinez, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [apps watch list1])

Attachments

(2 attachments)

Created attachment 746391 [details]
Screen shown in step 2

Tested on inari device with:

Vendor build id: 20130506003326
QC RIL: V1.01.00.01.019.094
Gaia commit: eeb713b657

STR:
1-After flashing the device, go through FTE without activating 3G connection nor connecting to a wifi
2-Open Facebook app
3-Activate 3G connection 
4-Open Facebook app
5-Deactivate 3G connection
6-Open Facebook app

Expected result --> Same screen should be shown in 2 and 6
Actual result --> Different screens are shown in 2 and 6
Created attachment 746393 [details]
Screen shown in step 6
This is invalid. You've cached resources here upon previous launches, so it makes complete sense that the content would load on 6.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
In tuenti app you´re getting the info (you´re offline) in the moment you open the app, no cache content is shown. In facebook you have to fill the data, click on enter and then you get the info, so you have to type everything again. I´m not a UX expert but as a user for me is a bad experience.
(In reply to Carlos Martínez Toral [:carlosmartinez] from comment #3)
> In tuenti app you´re getting the info (you´re offline) in the moment you
> open the app, no cache content is shown. In facebook you have to fill the
> data, click on enter and then you get the info, so you have to type
> everything again. I´m not a UX expert but as a user for me is a bad
> experience.

That's because cached content has already loaded for a past load of the app. That's by design.
Actually per earlier discussions today actually said this was a wont fix, not invalid. This is too cosmetic to warrant outreach.
Resolution: INVALID → WONTFIX
You need to log in before you can comment on or make changes to this bug.