If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Dialer][BB] Adapting the Call Log filters to the latest updates in the Tab BB

RESOLVED FIXED

Status

Firefox OS
Gaia::Dialer
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: gtorodelvalle, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18 fixed)

Details

Attachments

(1 attachment)

We need to adapt the tabs used in the Call Log for the call filtering ("all calls" vs. "missed call") to the latest changes in the Tab BB.
Depends on: 868388
Created attachment 746459 [details]
Associated PR.
Attachment #746459 - Flags: review?(crdlc)
Attachment #746459 - Flags: feedback?(arnau)
Comment on attachment 746459 [details]
Associated PR.

It is ok although there is a comment on github but I don't know if it would be useful or not, thanks German
Attachment #746459 - Flags: review?(crdlc) → review+
Hi Cristian! Indeed it was a more than appropriate comment ;-) In fact, it had no sense to listen to events at the element we have inside the one with the role="tab". I have included the needed changes to just deal with events at an element with role="tab" event. As you'll see, I had to include the "data-action" attribute in this level instead of in the inner .

I'll give you the change to have a new look at it before merging.

Thank you very much for your comments!
Flags: needinfo?(crdlc)
ok, thanks a lot, it makes sense
Flags: needinfo?(crdlc)
Merged in master: https://github.com/mozilla-b2g/gaia/commit/b2026cc332c8cd9f3e602367aca3421686740ab6
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 746459 [details]
Associated PR.

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Adaptation to new Tabs BBs (see bug 868388).
User impact if declined: UI issues and bad experience when using the Call Log.
Testing completed: Heavily tested in the device (normal and edit mode).
Risk to taking this patch (and alternatives if risky): Low.
String or UUID changes made by this patch: None.
Additional info: 2 changed files with 20 additions and 32 deletions.
Attachment #746459 - Flags: approval-gaia-v1?

Updated

4 years ago
Attachment #746459 - Flags: approval-gaia-v1? → approval-gaia-v1+
Uplifted b2026cc332c8cd9f3e602367aca3421686740ab6 to:
v1-train: 57b1808de1fc43227b517627e2598d4a97458085
status-b2g18: --- → fixed
Comment on attachment 746459 [details]
Associated PR.

Removing Arnau's need-info ;-) Thanks!
Attachment #746459 - Flags: feedback?(arnau)
You need to log in before you can comment on or make changes to this bug.