Highlights for focused element appearing too easily in about:healthreport

RESOLVED WORKSFORME

Status

Firefox Health Report
Web: Health Report
P5
normal
RESOLVED WORKSFORME
5 years ago
7 months ago

People

(Reporter: ge3k0s, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [measurement:client][polish])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
The focus ring appears in the header (Firefox Health Report - Raw Data) every time you click on these two items. It's a bit intrusive.

Also note that the focus ring isn't the right one on OSX.
Group: metrics-private
Component: Operations: Metrics/Monitoring → Metrics Operations
Product: Mozilla Services → Mozilla Metrics
Target Milestone: --- → Unreviewed
(Reporter)

Updated

5 years ago
Group: metrics-private
Component: Metrics Operations → Web: Health Report
Product: Mozilla Metrics → Firefox Health Report
Target Milestone: Unreviewed → ---
Version: unspecified → Trunk
(Reporter)

Updated

5 years ago
Blocks: 882493
Created attachment 8711025 [details]
focus_ring.PNG
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [polish]
Priority: -- → P5
Whiteboard: [polish] → [measurement:client][polish]
* load about:healthreport
* click on "raw data"
* move the mouse out of the "raw data" element
* notice dotted border (usually indicating input focus)
Summary: Focus rings appearing too easily in Health report → Highlights for focused element appearing too easily in about:healthreport

Comment 3

2 years ago
This is because the normalize.css that it includes (why!? This page will never render in anything but gecko...) has this rule:

a:focus {
    outline: thin dotted;
}


which they then try to "deal with" by using:

a:active,
a:hover {
    outline: 0;
}

which of course only helps as long as the element is active/hovered. So now it breaks. Remove those two rules and the problem goes away (tested with the devtools).

Comment 4

2 years ago
IMO we should remove the normalize.css and fix whatever fallout that produces.
(Reporter)

Comment 5

7 months ago
about:healthreport is going away in bug 1352497. Closing this bug in consequence.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.