Enormous table size majority of time page is loaded, with Javascript turned on

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
18 years ago
16 years ago

People

(Reporter: gary, Unassigned)

Tracking

Trunk
Future
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)
BuildID:    2001061804

In the page http://www.unison.ie/irish_independent/ the main table is has a 
huge horizontal size (tens of thousands of pixels) the majority of the time 
(over 95%).

Reproducible: Sometimes
Steps to Reproduce:
1. Make sure Javascript is turned on.
2. Go to http://www.independent.ie/irish_independent/


Actual Results:  The main table is usually rendered with a huge width.

Expected Results:  Mozilla should have created a normal-sized easily readable 
table.

Seems like bug 86075, except there is no <object> tag in the document.
However, the page always displays correctly when Javascript is turned off.
Computer is Windows 2000, I cannot reproduce the problem on the current Linux 
build.
(Reporter)

Comment 1

18 years ago
Tried this again with build 2001062104 (Windows 2000). Now, reloading page
generally works (maybe 49 out of 50 times). But clicking on a link, then going
back in the history always causes the problem.

The Java applet in the page is not rendered when the issue occurs (dark grey
box), but turning off Java has no effect on the problem appearing. Turning off
Javascript, though, still causes the problem to disappear.

I'll see if the next nightly build (with the fix for bug 86075) solves the problem.
(Reporter)

Comment 2

18 years ago
Problem seems to have been fixed with the fix for bug 86075.
I haven't seen the problem once in the last five days.Duplicate of 86075 I guess :)

Comment 3

18 years ago
Created attachment 40297 [details]
Same problem (?) with javascript-created flash object.

Comment 4

18 years ago
I've included the above testcase; it seems to be the same problem as bug 86075,
except caused by Javascript (will it ever go away?).

A few notes about the testcase:

- It comes the initial logged-in page of mail.yahoo.com, a fairly popular site.
 I see it quite regularly there.
- I've made it as minimal as possible.
- The trouble comes from the fact that the flash is inside a table cell with an
align attribute.  If the align attribute is marked "center" or "right", the
problem occurrs.  If the align attribute is missing or marked "left", the page
displays normally.
- The ADVERTISEMENT text correctly displays according to the align attribute
(centered or right-aligned), given the enormous width of the page; the flash
object displays just somewhere in that width, ignoring the align attribute.

I hope this is enough to confirm the bug; I've marked it NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

17 years ago
accept
Status: NEW → ASSIGNED

Comment 6

17 years ago
Temporarily moving to future until a milestone can be assigned. 
Target Milestone: --- → Future
(Reporter)

Comment 7

17 years ago
I can't reproduce the problem with the testcase from comment #3.
Seems to wfm with build 2002030604.

Comment 8

16 years ago
mass reassign to default owner
Assignee: karnaze → table
Status: ASSIGNED → NEW
Component: Layout → Layout: Tables
QA Contact: petersen → madhur
Target Milestone: Future → ---

Updated

16 years ago
Priority: -- → P3
Target Milestone: --- → Future

Comment 9

16 years ago
wfm win98 2003033108
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.