If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Force Marionette to use its own tab unless switch_to_window() is called.

RESOLVED FIXED in Firefox 24

Status

Testing
Marionette
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jgriffin, Assigned: jgriffin)

Tracking

unspecified
mozilla24
Points:
---

Firefox Tracking Flags

(firefox22 wontfix, firefox23 wontfix, firefox24 fixed, b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
We frequently use getMostRecentWindow() in marionette-actors.js in order to target the topmost window, but this can be unreliable (see bug 838607).  Instead, we should force Marionette to use the tab which it opens, unless switch_to_window() is used.
(Assignee)

Updated

4 years ago
Duplicate of this bug: 868365
(Assignee)

Comment 2

4 years ago
Created attachment 750768 [details] [diff] [review]
Make Marionette use its own tab on Firefox,

This solves the problem of identifying Marionette's frame by url ('about:blank'); when using the url, we were sometimes attaching to the wrong frame because other tabs will have an 'about:blank' url for a short time before their content (like the home page) is loaded.

We were already doing the right thing in getCurrentWindow...we were returning the current browser's window unless we didn't have a current browser.
Attachment #750768 - Flags: review?(mdas)
Comment on attachment 750768 [details] [diff] [review]
Make Marionette use its own tab on Firefox,

Review of attachment 750768 [details] [diff] [review]:
-----------------------------------------------------------------

::: testing/marionette/marionette-actors.js
@@ +2361,2 @@
>     * @param string href
>     *        frame's href 

can you update this docstring?
Attachment #750768 - Flags: review?(mdas) → review+
(Assignee)

Comment 4

4 years ago
Review comments addressed, landed as https://hg.mozilla.org/integration/mozilla-inbound/rev/c3b24901a518
Target Milestone: --- → mozilla24
https://hg.mozilla.org/mozilla-central/rev/c3b24901a518
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Duplicate of this bug: 861810
(Assignee)

Comment 7

4 years ago
checkin-needed for mozilla-b2g18 and 1.0.1 please
Keywords: checkin-needed
https://hg.mozilla.org/releases/mozilla-b2g18/rev/adda2ea6d1d1
https://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/047b7010c99a
status-b2g18: --- → fixed
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → fixed
status-firefox22: --- → wontfix
status-firefox23: --- → wontfix
status-firefox24: --- → fixed
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.