Mozilla Installer On Windows Is Not Setting App Paths Key

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: lmcquarr, Assigned: ssu0262)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
The mozilla installer needs to modify this registry entry with its
application path:

HKEY_LOCAL_MACHINE\software\microsoft\windows\CurrentVersion\App paths\

For example, it would add the key "Mozilla.exe" with a default value of
"<path to mozilla executable>"


This key is used by Acrobat, Eudora, etc  that support 
DDE to know how to launch whatever application registered itself
as the handler for:

HKEY_LOCAL_MACHINE\software\\classes\\http\\shell\\open\\ddeexec\\application


(Note: Netscape6 properly puts its app path in the registry entry.)
(Assignee)

Comment 1

18 years ago
What's the url of the mozilla build that this is not happening on?  I'm looking 
the code for mozilla that's supposed to be doing this, and it is.

The only think I can think of that is happening is that users who run in the 
acrobat problem installed mozilla using the .zip file, which does not modify the 
windows registry at all.

Mozilla's .exe installer should be doing it already.
(Reporter)

Comment 2

18 years ago
Hello:  I have been using the zip file.  Excuse me for asking a naive
question, but where can I actually find an installable mozilla?
(Reporter)

Comment 4

18 years ago
I have found the installable version and indeed, the app paths are set 
correctly.

Sorry -- this is not a bug  (it can be closed).

(Assignee)

Comment 5

18 years ago
closing bug
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 6

17 years ago
worksforme  build 20010816
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.