Starred contacts don't display in contact list

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Contacts
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Bartosz Piec, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 746591 [details]
Correct view (1st)

Because contacts sometimes disappear (bug 869620) and the last calls didn't display (bug 869126) I starred several contacts to call them faster.
All starred contacts are displayed on the 1st screenshot but it is very rare view. Sometimes it looks like the 2nd screenshot and after the reboot like the 3rd screenshot (generally ‒ randomized). You can see that sometimes the contacts are duplicated.

Note that I have ~350 contacts and didn't add/remove any contacts between these screenshots.
(Reporter)

Comment 1

5 years ago
Created attachment 746592 [details]
Broken view (2nd)
(Reporter)

Comment 2

5 years ago
Created attachment 746593 [details]
Broken view (3rd, after the reboot)
(Reporter)

Updated

5 years ago
blocking-b2g: --- → tef?
(Reporter)

Updated

5 years ago
Blocks: 869646
Bartosz, can you please tell us which version of gecko (b2g18? m-c?), and gaia (master, v1.0.1, v1-train ?)

Thanks.
(Reporter)

Comment 4

5 years ago
Gecko 18, v1.0.1 branch.
Hi just tried with a fresh user build from b2g-18 and gaia v1.0.1 and I'm not able to reproduce the problem.

@Bartosz could you try again?

Thanks!
F.
Flags: needinfo?(bpiec)
Keywords: qawanted
Haven't yet been able to reproduce using:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/b0b2b5cfdc5b
Gaia   30ad443fbe5363a7381c19c6bf9d6ca49228fb8b
BuildID 20130509070209
Version 18.0

Where did the contacts get imported from? Facebook or SIM import or both?
Keywords: qawanted
Closing as works for me, as we were not able to reproduce.

Please reopen if you find again the issue.

Thanks!
F.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
blocking-b2g: tef? → ---
(Reporter)

Comment 9

5 years ago
I just switched to v1-train branch, imported my contacts from Gmail and the sorting is still broken. Does that confirm this bug?
Flags: needinfo?(bpiec)
(Reporter)

Comment 10

5 years ago
I just switched to v1-train branch, imported my contacts from Gmail and the starring is still broken. Does that confirm this bug?

Comment 11

5 years ago
Issue repros on 
Unagi Build ID: 20130514070207
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/58e5ff2fcfce
Gaia: 9841cfc141e3f849aba780592e02a482b17eb570

When user importing Gmail contacts the Star feature is broken.  When staring a contact it is shown twice.
You need to log in before you can comment on or make changes to this bug.