pdf crashing on today's builds

VERIFIED DUPLICATE of bug 80105

Status

()

--
critical
VERIFIED DUPLICATE of bug 80105
18 years ago
16 years ago

People

(Reporter: shrir, Assigned: serhunt)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
today's trunk on win..

trying to load almost any pdf file crashes...

stack :
pluginInstanceOwner::~pluginInstanceOwner 
[d:\builds\seamonkey\mozilla\modules\plugin\nglsrc\nsPluginViewer.cpp, line 959] 
pluginInstanceOwner::`scalar deleting destructor' 
pluginInstanceOwner::Release 
[d:\builds\seamonkey\mozilla\modules\plugin\nglsrc\nsPluginViewer.cpp, line 961] 
PluginViewerImpl::~PluginViewerImpl 
[d:\builds\seamonkey\mozilla\modules\plugin\nglsrc\nsPluginViewer.cpp, line 292] 
PluginViewerImpl::`scalar deleting destructor' 
PluginViewerImpl::Release 
[d:\builds\seamonkey\mozilla\modules\plugin\nglsrc\nsPluginViewer.cpp, line 264] 
nsCOMPtr_base::assign_with_AddRef 
[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp, line 59] 
PresShell::UnsuppressAndInvalidate 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4531] 
PresShell::UnsuppressAndInvalidate 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4531] 
PresShell::UnsuppressPainting 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4565] 
DocumentViewerImpl::LoadComplete 
[d:\builds\seamonkey\mozilla\content\base\src\nsDocumentViewer.cpp, line 1129] 
nsDocShell::EndPageLoad 
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 3645] 
nsWebShell::EndPageLoad 
[d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp, line 907] 
nsDocShell::OnStateChange 
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 3566] 
nsDocLoaderImpl::FireOnStateChange 
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 1095] 
nsDocLoaderImpl::doStopDocumentLoad 
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 734] 
nsDocLoaderImpl::DocLoaderIsEmpty 
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 632] 
nsDocLoaderImpl::OnStopRequest 
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 563] 
nsLoadGroup::RemoveRequest 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsLoadGroup.cpp, line 517] 
PresShell::RemoveDummyLayoutRequest 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6105] 
PresShell::ProcessReflowCommands 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5891] 
ReflowEvent::HandleEvent 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5677] 
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591] 
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, 
line 524] 
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 
1072]
(Assignee)

Comment 1

18 years ago
OK, this crash on leaving the page is a dup of bug 80105, more precisely its 
remaining issue which is pending approval to check in. The real issue is the 
alleged crash on loading the page. Do you see that?
(Reporter)

Comment 2

18 years ago
The first time, pdf's either load completely or I see a blank (bug 76892). When 
I enter another url or cut-psate a url in the url bar and hit enter ..then the 
browser crashes just while loading it 

test urls :
http://www.licel.com/R7400U.pdf
http://www.ipservices.att.com/ipaccess/gvpns/2000vpn.pdf
http://www.svbus.com/KeyStoneUG.pdf
http://access.adobe.com/browser/netscape/net6.pdf

Comment 3

18 years ago
nsPluginViewer.cpp....this isn't my crash--->Andrei
Assignee: peterlubczynski → av

Comment 4

18 years ago
Yes, it crashes when leaving the page for shrirang because he doesn't have the
NS_IF_RELEASE for full-page yet. 

Andrei, the other crash I was seeing when away with a clobber (alas too many
changes). Marking dup 80105

*** This bug has been marked as a duplicate of 80105 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

18 years ago
*** Bug 87128 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 6

16 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.