Closed Bug 869777 Opened 7 years ago Closed 7 years ago

Work - Navigation bar "choppy" when dismissing while in snapped view

Categories

(Firefox for Metro Graveyard :: App Bar, defect)

x86_64
Windows 8.1
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: kjozwiak, Assigned: ally)

References

Details

(Whiteboard: feature=work)

Attachments

(1 file)

When dismissing the navigation bar in snapped view, you will notice that it will have this "choppy" motion to it before being dismissed correctly after the first time around.

Steps to reproduce the issue:

1) Open Firefox Metro
2) Place Firefox Metro into "Snapped View"
3) Once in "Snapped View", visit any website
4) Once the website has been loaded, slide in the navigation bar (it will be very smooth and as expected)
5) Dismiss the navigation bar (should be smooth the first time around)
6) Repeat Step # 4 & 5 and you will notice that dismissing the navigation bar will be a little "choppy"

Current Behavior:

- When dismissing the navigation bar while in snapped view, you will notice that the dismissal is not smooth and its a bit "choppy"

Expected Behavior:

- Should be dismissed as smooth as sliding the navigation bar into view every single time.
No longer blocks: metrov1defect&change
Summary: Defect - Navigation bar "choppy" when dismissing while in snapped view → Work - Navigation bar "choppy" when dismissing while in snapped view
Whiteboard: feature=defect c=firefox_app_bar_and_autocomplete u=metro_firefox_user p=0 → feature=work
Assignee: nobody → ally
looks like the close animation is starting in the wrong spot in snapped.

I see the following: the swipe triggers the animation, which briefly, jumps the nav bar down much lower (as if there were a tabstrip there) and then animates it back through closing the same way it does on desktop.
I hypothesize that http://mxr.mozilla.org/mozilla-central/source/browser/metro/theme/browser.css#17 ((-@tray_slide_height@)) is taking the height of the tabstrip into account when it should not be.
I was half right. The other half is a margin that is present on one transition but not the other, and we don't really need hanging about.

The only down side is the bounce on the start snapped page, https://bugzilla.mozilla.org/show_bug.cgi?id=865567#c2, is removed by this fix.

Thanks to :fryn for his help.
Attachment #748319 - Flags: feedback?(mbrubeck)
Attachment #748319 - Flags: feedback?(mbrubeck) → feedback+
Attachment #748319 - Flags: review?(mbrubeck)
Attachment #748319 - Flags: review?(mbrubeck) → review+
Blocks: 835623
Blocks: 867115
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/e9e0810ff90c
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Went through the following "Defect" and Tested/Verified that the issue has been resolved. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-05-25-06-25-25-mozilla-central/

- Went through the original test cases in Comment 0 and ensured that it worked without any issues (both in Snapped and Filled View)
- Used the "Windows + Z" shortcut and ensured that it worked without any issues (both in Snapped and Filled View)
- Ensured that there was no issues when attempting to dismiss the "Navigation App Bar" on the awesome screen while in Snapped View
Status: RESOLVED → VERIFIED
Went through the following "Defect" for iteration #9 testing without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-06-25-03-12-38-mozilla-central/

- Went through the original test case from comment 0 without any issues
- Went through the test cases outlined in comment 6 without any issues
- Ensured that the "Tab Bar" at the top was dismissed when going into snapped view from full/filed view
- Ensured that sliding in the "Navigation App Bar" several times on a website worked without any issues
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.