If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

()

Core
Plug-ins
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Dan Jacobson, Unassigned)

Tracking

22 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:22.0) Gecko/20130503 Firefox/22.0 Iceweasel/22.0a2
Build ID: 20130503004014

Steps to reproduce:

Browsed http://www.nbcnews.com/video/nightly-news/51810239/#51810239
in pristine Firefox.


Actual results:

Half the screen is white.

Comment 1

4 years ago
you should install Flash Player.
(Reporter)

Comment 2

4 years ago
I'm saying how could a major website, view in a major browser, be such a disaster?

I purposely used a pristine Firefox for this test.
(Reporter)

Comment 3

4 years ago
"You should install Flash Player" was not seen in the white area.
If that is what one should do, then the browser should say that to the user.

Comment 4

4 years ago
The website does it for you, see this disclaimer: http://media1.s-nbcnews.com/i/msnbc/Components/Video/_Player/configurations/videoRequirementAssets/UFS.jpg
(Reporter)

Comment 5

4 years ago
Can you please try this to get the white half screen,
su - nobody -c 'HOME=/tmp/$$ firefox http://www.nbcnews.com/video/nightly-news/51810239/#51810239'

I notice it has found flashplayer on its own not that I wanted it to, but the screen is all white.
I can't reproduce this issue with the latest Nightly build (build ID: 	20130513031057).

If you installed Flash, could you please update your GPU driver?

Could you please also try the following, to see if you still reproduce the issue :

1) try this with a clean profile: http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

2) running in Safe mode: http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
Component: Untriaged → Plug-ins
Product: Firefox → Core

Updated

4 years ago
Flags: needinfo?(jidanni)
(Reporter)

Comment 7

4 years ago
1. My "su nobody" is much 'cleaner' and much 'safer' that the above.
2. On my 1MB ADSL line (slow) I can see what is really going on. Apparently we are staring at a half white screen waiting for it to download something... As in fact my connection meter shows tons of bytes flowing...

# su - nobody -c 'HOME=/tmp/$$ firefox http://www.nbcnews.com/video/nightly-news/51810239/#51810239'
No directory, logging in with HOME=/

(process:10716): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4727:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2227:(snd_pcm_open_noupdate) Unknown PCM default

... upon which it was already taking too long, so I killed it.
Flags: needinfo?(jidanni)
So it sounds like you are seeing this due a slow or bad connection and the Flash content simply doesn't finish downloading fast enough?
Flags: needinfo?(jidanni)
(Reporter)

Comment 9

4 years ago
OK but can you confirm that the whole first screenful of that page remains totally white for at least a full minute at least (with a 1MB connection.)
Flags: needinfo?(jidanni)
On OS X, when artificially limiting my bandwidth, it takes half a minute until it shows the loading indicator, while it's fine otherwise. 
Your connection quality may differ, so there doesn't seem to be anything broken here.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Reporter)

Comment 11

4 years ago
So their website design is extremely poor?
Possibly, it looks like it wasn't tested it with slower connection speeds - it should at least show a loading indicator in that time.
Note how the behaviour in other browsers is the same when loading it the first time, but how it's fine once it's cached.

Comment 13

4 years ago
Flash player appears on 192kbps network environment, It takes about 60-80seconds.
You need to log in before you can comment on or make changes to this bug.