Closed Bug 869818 Opened 7 years ago Closed 7 years ago

Nightly: Segfault in mousewheel-zooming

Categories

(Firefox :: Untriaged, defect)

23 Branch
x86
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 868904

People

(Reporter: grin, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:10.0) Gecko/20100101 Firefox/10.0

Steps to reproduce:

1) http://www.openstreetmap.org/browse/changeset/14498574
2) mouewheel zoom in the map in the right top

So far it seems reproducible, at least after session restore I can crash it again.



Actual results:

SIGSEGV (not handled by crash reporter)

#0  0xb6d771b6 in SearchTable(PLDHashTable*, void const*, unsigned int, PLDHashOperator) () from /storage/firefox-nightly/libxul.so
#1  0xb6d77c45 in PL_DHashTableOperate () from /storage/firefox-nightly/libxul.so
#2  0xb68ac3f4 in nsPropertyTable::GetPropertyInternal(nsPropertyOwner, nsIAtom*, bool, tag_nsresult*) () from /storage/firefox-nightly/libxul.so
#3  0xb689efa8 in nsINode::GetProperty(unsigned short, nsIAtom*, tag_nsresult*) const () from /storage/firefox-nightly/libxul.so
#4  0xb6741786 in ElementTransitions* HasAnimationOrTransition<ElementTransitions>(nsIContent*, nsIAtom*, nsCSSProperty) () from /storage/firefox-nightly/libxul.so
#5  0xb67419e0 in nsLayoutUtils::HasAnimationsForCompositor(nsIContent*, nsCSSProperty) () from /storage/firefox-nightly/libxul.so
#6  0xb6785ae3 in nsIFrame::IsTransformed() const () from /storage/firefox-nightly/libxul.so
#7  0xb67c69be in mozilla::css::CommonElementAnimationData::CanAnimatePropertyOnCompositor(mozilla::dom::Element const*, nsCSSProperty, mozilla::css::CommonElementAnimationData::CanAnimateFlags) () from /storage/firefox-nightly/libxul.so
#8  0xb6824867 in ElementTransitions::CanPerformOnCompositorThread(mozilla::css::CommonElementAnimationData::CanAnimateFlags) const () from /storage/firefox-nightly/libxul.so
#9  0xb67417ba in ElementTransitions* HasAnimationOrTransition<ElementTransitions>(nsIContent*, nsIAtom*, nsCSSProperty) () from /storage/firefox-nightly/libxul.so
#10 0xb67419e0 in nsLayoutUtils::HasAnimationsForCompositor(nsIContent*, nsCSSProperty) () from /storage/firefox-nightly/libxul.so
#11 0xb6785ae3 in nsIFrame::IsTransformed() const () from /storage/firefox-nightly/libxul.so
#12 0xb67c69be in mozilla::css::CommonElementAnimationData::CanAnimatePropertyOnCompositor(mozilla::dom::Element const*, nsCSSProperty, mozilla::css::CommonElementAnimationData::CanAnimateFlags) () from /storage/firefox-nightly/libxul.so
#13 0xb6824867 in ElementTransitions::CanPerformOnCompositorThread(mozilla::css::CommonElementAnimationData::CanAnimateFlags) const () from /storage/firefox-nightly/libxul.so
#14 0xb67417ba in ElementTransitions* HasAnimationOrTransition<ElementTransitions>(nsIContent*, nsIAtom*, nsCSSProperty) () from /storage/firefox-nightly/libxul.so
#15 0xb67419e0 in nsLayoutUtils::HasAnimationsForCompositor(nsIContent*, nsCSSProperty) () from /storage/firefox-nightly/libxul.so
#16 0xb6785ae3 in nsIFrame::IsTransformed() const () from /storage/firefox-nightly/libxul.so
#17 0xb67c69be in mozilla::css::CommonElementAnimationData::CanAnimatePropertyOnCompositor(mozilla::dom::Element const*, nsCSSProperty, mozilla::css::CommonElementAnimationData::CanAnimateFlags) () from /storage/firefox-nightly/libxul.so
#18 0xb6824867 in ElementTransitions::CanPerformOnCompositorThread(mozilla::css::CommonElementAnimationData::CanAnimateFlags) const () from /storage/firefox-nightly/libxul.so
#19 0xb67417ba in ElementTransitions* HasAnimationOrTransition<ElementTransitions>(nsIContent*, nsIAtom*, nsCSSProperty) () from /storage/firefox-nightly/libxul.so
#20 0xb67419e0 in nsLayoutUtils::HasAnimationsForCompositor(nsIContent*, nsCSSProperty) () from /storage/firefox-nightly/libxul.so
#21 0xb6785ae3 in nsIFrame::IsTransformed() const () from /storage/firefox-nightly/libxul.so
#22 0xb67c69be in mozilla::css::CommonElementAnimationData::CanAnimatePropertyOnCompositor(mozilla::dom::Element const*, nsCSSProperty, mozilla::css::CommonElementAnimationData::CanAnimateFlags) () from /storage/firefox-nightly/libxul.so
[..cut for brevity..]



Expected results:

Javascript-handled zooming, no crash.
OS: Windows 7 → Linux
User agent: Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20130507 Firefox/23.0
(Seems some manual overrides were in effect, eek!)
maybe duplication of Bug 868904
Fixed in
http://hg.mozilla.org/mozilla-central/rev/b980d32c366f
Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20130508 Firefox/23.0 ID:20130508031113
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 868904
You need to log in before you can comment on or make changes to this bug.