[B2G][Leo][SMS] It is possible to invoke the Email APP clicking on a invalid text (email address) included in a SMS

RESOLVED WONTFIX

Status

Firefox OS
Gaia::SMS
RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: bov, Unassigned)

Tracking

unspecified
x86
Windows 7

Firefox Tracking Flags

(blocking-b2g:-, b2g18+)

Details

(Whiteboard: permafail)

(Reporter)

Description

5 years ago
TESTED ON A LEO DEVICE. Build ID: 20130425170448. Gaia: f9d8af0

STEPS:
1. Send a sms from "device A" to "device B" which contains a text " \b[A-Z0-9._%-]+@[A-Z0-9.-]+\.[A-Z]{5,X}\b" example: "aaaa@aaa.aaaaa"
2. Open sms app in the device A.
3. Open the thread view in the device A
4. Click on the text

EXPECTED RESULT:
The text will not be highlighted and the user can't click on the text

ACTUAL RESULT:
"aaaa@aaa.aaaaa" appears highlighted, and tapping on it, the email app is launched, and it is possible to send an email to "aaaa@aaa.aaaaa" without errors

Comment 1

5 years ago
Just to clarify. As per the WF, the valid email address will be determined by using the following regular expression \b[A-Z0-9._%-]+@[A-Z0-9.-]+\.[AZ]{2,4}\b.

https://bug838003.bugzilla.mozilla.org/attachment.cgi?id=725421 Page 7

The regular expression used in the test case is to test an invalid email address.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo?

Comment 2

5 years ago
Not a regression, and an edge case. If the user sends an email, the server will notify them of the invalid address.
blocking-b2g: leo? → -

Updated

5 years ago
tracking-b2g18: --- → +
FWIW, according to gmail, "aaaa@aaa.aaaaa" is a valid email address
(Reporter)

Comment 4

5 years ago
This issue tested on Leo 1.1 (Test Run Firefox OS 1.1.0 Full – Leo)
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8e3f39363c54
Gaia: ea18de80fd04110756becaed214656642388401d
Platform Version: 18.0

STEPS:
1. Send a sms from another device to the DUT with the text "aaaa@aaa.aaaaa"
2. Open sms app in the DUT
3. Open the thread view in the DUT
4. Click on the text "aaaa@aaa.aaaaa"

EXPECTED RESULT:
The text "aaaa@aaa.aaaaa" will not be highlighted and the user can't click on the text.

Valid e-mail address will be determined by using a regular expression (e.g. \b[A-Z0-9._%-]+@[A-Z0-9.-]+\.[AZ]{2,4}\b), according WF (HTML5_SMS-MMSUserStorySpecifications_20130503_V8.0)

ACTUAL RESULT:
"aaaa@aaa.aaaaa" appears highlighted, and tapping on it, the email app is launched, and it is possible to send an email to "aaaa@aaa.aaaaa" without errors. Later the user recieved an email Delivery Status error from the server because the domain doesn't exist.

Link to failed test case:
https://moztrap.mozilla.org/manage/case/7175/
Whiteboard: leorun1 → leorun1, leorun3
(Reporter)

Comment 5

5 years ago
This issue tested on Leo 1.1 (Test Run Firefox OS 1.1.0 Full – Leo Run 4)
Gecko a378807ff04076c20f08b0102286b9eb2d08d60a
Gaia 1436e2778b90bd74635b0b94d1cf8ccb0d71b60c
Platform Version: 18.1

STEPS:
1. Send a sms from another device to the DUT with the text "aaaa@aaa.aaaaa"
2. Open sms app in the DUT
3. Open the thread view in the DUT
4. Click on the text "aaaa@aaa.aaaaa"

EXPECTED RESULT:
The text "aaaa@aaa.aaaaa" will not be highlighted and the user can't click on the text.

Valid e-mail address will be determined by using a regular expression (e.g. \b[A-Z0-9._%-]+@[A-Z0-9.-]+\.[AZ]{2,4}\b), according WF (HTML5_SMS-MMSUserStorySpecifications_20130503_V8.0)

ACTUAL RESULT:
"aaaa@aaa.aaaaa" appears highlighted, and tapping on it, the email app is launched, and it is possible to send an email to "aaaa@aaa.aaaaa" without errors. Later the user recieved an email Delivery Status error from the server because the domain doesn't exist.

Link to failed test case:
https://moztrap.mozilla.org/manage/case/7175/
Whiteboard: leorun1, leorun3 → leorun1, leorun3, leorun4

Updated

5 years ago
Whiteboard: leorun1, leorun3, leorun4 → leorun1, leorun3, leorun4, retest_leorun4

Updated

4 years ago
Whiteboard: leorun1, leorun3, leorun4, retest_leorun4 → leorun1, leorun3, leorun4, retest_leorun4, burirun3
aaaa@aaa.aaaaa is a valid email. Remember we have very long TLD these days (like .museum) and that arbitrary TLD will soon be able to be used.

So I think we should not fix this, I'll close this bug then.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX

Comment 7

4 years ago
moving to "permafail" to clean up my queries, noted as a no-fix nonetheless.
Whiteboard: leorun1, leorun3, leorun4, retest_leorun4, burirun3 → permafail
You need to log in before you can comment on or make changes to this bug.