Closed Bug 869947 Opened 11 years ago Closed 11 years ago

Show friendly message when carrier is not supported for Bango billing

Categories

(Marketplace Graveyard :: Payments/Refunds, defect, P5)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 858690

People

(Reporter: kumar, Assigned: simone)

References

Details

STR:
- start on wifi
- purchase Private Yacht
- log in
- enter PIN
- do SMS confirmation with an unsupported carrier

Expected: the user sees a friendly message explaining that their carrier is unsupported

Actual: you see the generic "there was an error processing that request"

Example of an error redirect we get from Bango in this situation (bug 869894):

May  8 03:53:54 localhost6.localdomain: [None] w.bango:INFO Bango error: <QueryDict: {u'BillingConfigurationId': [u'233770'], u'ResponseCode': [u'NOT_SUPPORTED'], u'P': [u''], u'Currency': [u'GBP'], u'BangoUserId': [u'1530867445'], u'MerchantTransactionId': [u'webpay:118d90a4-432f-43da-9bd6-ef482c9310d6'], u'MozSignature': [u'240a0cedfc9e4d4f97e07ec55673161e7117cae4a7775789e2257f053eb07261'], u'ResponseMessage': [u'The user or operator (e.g. MVNO) is not supported by the biller'], u'BangoTransactionId': [u'0'], u'TransactionMethods': [u''], u'Price': [u'0.75'], u'Network': [u'GBR_THREE']}> :/data/www/marketplace-dev.allizom.org-webpay/webpay/webpay/bango/views.py:85
Priority: -- → P3
Flags: affects-tricycle+
Flags: affects-seville+
Flags: affects-seahorse+
Flags: affects-moss+
Flags: affects-durango+
Severity: normal → trivial
Priority: P3 → P5
Version: 1.2 → 1.3
Because Steve said so :)
Assignee: nobody → tom
Version: 1.3 → 1.4
dupe of 865656
Assignee: tom → Jim
Version: 1.4 → 1.5
Assignee: Jim → simone
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.