SVG paths of zero length are not stroked

RESOLVED DUPLICATE of bug 648266

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 648266
5 years ago
5 years ago

People

(Reporter: Tom MacWright, Unassigned)

Tracking

20 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 746955 [details]
index.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.73 Safari/537.36

Steps to reproduce:

Created an SVG path of length zero (two points, no distance between them) and styles to stroke that path.


Actual results:

No stroke appears.


Expected results:

In other browsers, a circle is drawn for the stroke of the zero-length path.

Updated

5 years ago
Attachment #746955 - Attachment mime type: text/plain → text/html

Updated

5 years ago
Component: Untriaged → SVG
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 648266
You need to log in before you can comment on or make changes to this bug.