'?src=' creates url aliases, defeats AMO's a:visited style, browser bookmarks, etc.

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: Alan Jenkins, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130401133302

Steps to reproduce:

Use the search function on AMO.


Actual results:

The links in the search results add '?src=search' to the URL of each addon.  Clicking the link visits the URLs with this parameter added.  There is no redirect to the canonical URL.

This is harmful, as explained by the W3C.  http://www.w3.org/TR/webarch/#uri-aliases

It is a bug because AMO appears to have an a:visited style.  To be consistent, the :visited style should be applied regardless of whether I visited the addon through the search, or through some other method (e.g. direct link from another site).

Also it means if I click on an addon I have already bookmarked, it doesn't show the star in my location bar!  This is a bug, because
 - it's common for me to revisit a bookmarked page, and re-organize the tags for that bookmark
 - firefox's bookmark tags are the only real solution, to avoid unreliably guessing keywords for Google in order to find pages I've already engaged with in the past.


Expected results:

- Links on AMO to individual addon pages should always arrive at the same URL.  The URLs arrived at should not vary depending on the source page (e.g. search v.s. collections).

- AMO's :visited styles need to be applied in the same way, for consistency with normal website behaviour.  Therefore it is not sufficient to redirect the parameterized URL to the canonical version.  The canonical version should be used as the link target.

- other goals e.g. analytics could usually be satisfied by tracking Referer, or by using Javascript.  If the analytics are truly essential, then progressive enhancement can still be used.

In this case the _enhancement_ when javascript is enabled would be to fixup the fugly URL design (and hence all its deleterious effects).  HTTP redirects to the canonical URLs could be enabled.  So the progressive enhancement would be to 1) reduce latency 2) fix the :visited styling... though actually it would be better for no-JS to disable the :visited styling altogether.  Rather than having an inconsistent styling, that changes to a consistent one when JS is enabled.  (Crazy people like me use the NoScript extension, to toggle JS dynamically).
(Reporter)

Updated

5 years ago
Summary: '?src=' creates url aliases, defeats browser bookmarks, AMO's a:visited style etc. → '?src=' creates url aliases, defeats AMO's a:visited style, browser bookmarks, etc.
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.