Message filter is deactivating filters

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
18 years ago
11 years ago

People

(Reporter: redwolf, Assigned: naving)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.1) Gecko/20010607
BuildID:    2001060703

Message filter is deactivating some filters. Turning filter back on is effective
until a message arrives that uses the dodgy filter, then it deactivates again.

Reproducible: Always
Steps to Reproduce:
1. Turn message filter on
2. Message relevant to filter arrives, filter is deactivated

Actual Results:  Incoming message is dumped in either the inbox or the trash, as
the filter has been deactivated

Expected Results:  Incoming message should go to appropriate folder

This is only happening on two filters at the moment. I do not know why it is
these filters and not others. Deleting the affected filter and recreating it
seems to fix the problem.

Comment 1

18 years ago
Jodi, can you post your rules.dat file?  This may be a dup of a bug I am working on.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
Likely caused by folder path problem? ref bug 41720 as base bug.

Comment 3

18 years ago
Ok, I have the same problem and have more informations on this.

The woraround is: Open the Mailfolder  on the righthand side of your Mail. If
you want to Filter Mail from your Inbox to Local-Mail->Majordomo->Listname you
need to see the subfolder on the righthand side. If the folder is collapsed the
Filter gets deactivated. This is allways reproducible.

Steps to Reproduce:

1. Create Folder in Local-Mail (e.g. Local-Mail->Majordomo->lk)
2. Collapse Local-Mail on the righthand side (Only Local-Mail is seen)
3. Create Filter for an Imap/Pop-Account that moves some messages to
   the newly created subfolder on Local-Mail
4. The first messages that is matched by the filter deactivates the
   filter.

Comment 4

18 years ago
Oh, I forgot some infos:

I am using Linux with the latest nightly build of mozilla.

Comment 5

18 years ago
Martin, can you re-try your testcase with a newer nightly build (downloadable
from www.mozilla.org) ?

Comment 6

18 years ago
Created attachment 39910 [details]
Martin's rules.dat, emailed to me privately

Comment 7

18 years ago
Martin / Jodi:

1. Does it work with a nightly build from mozilla.org from today?
2. Try editing one of the filters that turns off themselves, and correct the
path. The folder path may be corrupt (in such cases, we auto-disable)

Please try both those, maybe in combination, and report back. Thanks!

Comment 8

18 years ago
1. Yes, it does work with the nightly build from today.
2. Pathes in the rules.dat-file were ok. (as expected, because reenabling the
Folder and Extending Local Mails helped to get the rule work again in previous
versions.

So from my side this bug ist fixed with the latest nightly build.

Comment 9

18 years ago
Sorry. 2. should read reenabling the rule of course.

Comment 10

18 years ago
Marking verified worksforme.
(underlying bug 41720)
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 11

18 years ago
.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.