Closed Bug 870120 Opened 7 years ago Closed 7 years ago

[SMS] maxSegmentsInfo no longer working with new MMS compatible composer

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect, P1)

x86
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:leo+, b2g18 fixed)

RESOLVED FIXED
1.1 CS (11may)
blocking-b2g leo+
Tracking Status
b2g18 --- fixed

People

(Reporter: danheberden, Assigned: gnarf)

References

Details

Attachments

(3 files)

_mozMobileMessage.maxSegmentsInfo no longer working with new MMS compatible composer - this should be mocked in tests and have tests written to verify its operation.
Priority: -- → P1
Whiteboard: dev-branch
Target Milestone: --- → 1.1 CS (11may)
Whiteboard: dev-branch → dev-branch [NO_UPLIFT]
Depends on: 840069
Flags: needinfo?(aymanmaat)
Assignee: nobody → gnarf37
Flags: needinfo?(aymanmaat)
Attached image maxSegments not working
The max-lenght is not working, so you can type more text if you want despite of reaching the max number of characters.
Here we have 2 things to fix:
- Fix Tests
- Fix the max-lenght issue
blocking-b2g: --- → leo+
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 870124
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Whiteboard: dev-branch [NO_UPLIFT] → [NO_UPLIFT]
Attachment #748301 - Flags: review?(fbsc)
Depends on: 870124
The max length work should be removed with the MMS stuff anyway, that was the plan from the start.

With MMS, AFAIK we should not prevent the user from adding more characters and convert the message to MMS instead, so this is a completely different use case, and should be done again from the ground up.

As I said, this was the plan.
> With MMS, AFAIK we should not prevent the user from adding more characters
> and convert the message to MMS instead, 

True.
Comment on attachment 748301 [details] [diff] [review]
https://github.com/bocoup/gaia/pull/11

r+ for this patch, but consider whether you could just switch the keydown handler to keypress.

I also wonder whether the composeLockCheck() function should actually set locked to false, or if it should just leave that for the composeCheck() function to do.  (Unless no 'input' event is generated on backspace.)
Attachment #748301 - Flags: review?(fbsc) → review+
Whiteboard: [NO_UPLIFT] → [NO_UPLIFT] dev-branch
https://github.com/mozilla-b2g/gaia/commit/ac229186a02a05e1e0cd998fff0ad7511bf30a63
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Whiteboard: [NO_UPLIFT] dev-branch → [NO_UPLIFT]
Whiteboard: [NO_UPLIFT]
v1-train: 5c6a147
You need to log in before you can comment on or make changes to this bug.