[Call log] The 'Day' indicator disappears after moving to Missed calls tab

RESOLVED FIXED in 1.1 QE2 (6jun)

Status

P2
major
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: leo.bugzilla.gaia, Assigned: mihai)

Tracking

unspecified
1.1 QE2 (6jun)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18+ verified)

Details

(Whiteboard: [TD-25245], MiniWW, URL)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 747195 [details]
Day indicator disappears

1. Title : The 'Day' indicator disappears after moving to Missed calls tab
2. Precondition : Call logs exist unitl 2days
3. Tester's Action : Scroll down >> Select missed call tab
4. Detailed Symptom : The 'Day' indicator disappears
5. Expected : The 'Day' indicator is represented normally
6. Reproducibility: Y
1) Frequency Rate : 100%
7. Gaia Master/v1-train : Reproduce
8. Gaia Revision : 5cbb19e4bb78a7ad879fbe4b9a841e1c35714f5c
9 Personal email id : promise09th@gmail.com
(Reporter)

Updated

6 years ago
blocking-b2g: --- → leo?
(Reporter)

Updated

6 years ago
Whiteboard: [TD-25245]
This bug fix will likely be high effort for low return. Tracking instead of blocking.
blocking-b2g: leo? → -
tracking-b2g18: --- → +

Updated

6 years ago
Target Milestone: --- → 1.1 QE2
Assignee: nobody → mihai
Whiteboard: [TD-25245] → [TD-25245], u=fx-os-user c=may-20-31 p=1
Whiteboard: [TD-25245], u=fx-os-user c=may-20-31 p=1 → [TD-25245], u=fx-os-user c=scravag-sprint-may-20-31 p=1
Whiteboard: [TD-25245], u=fx-os-user c=scravag-sprint-may-20-31 p=1 → [TD-25245]
(Reporter)

Updated

6 years ago
Priority: -- → P2
Created attachment 751506 [details]
Pull Request #9867 - Fix 'day' header behaviour

Apparently the bug was caused by the incorrect check of the offset when scrolling, took me a while to pin point this :)
Attachment #751506 - Flags: review?(etienne)
Comment on attachment 751506 [details]
Pull Request #9867 - Fix 'day' header behaviour

wow, thanks!
Attachment #751506 - Flags: review?(etienne) → review+
Landed on master:
https://github.com/mozilla-b2g/gaia/commit/50cec689e9c894937d51dd37c6c22defcf2dce40
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Comment on attachment 751506 [details]
Pull Request #9867 - Fix 'day' header behaviour

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Call Log > date header
User impact if declined: Low (the top date header of Missed Calls disappears if user scrolls in All Calls)
Testing completed: Yes
Risk to taking this patch (and alternatives if risky): Low
String or UUID changes made by this patch: No
Attachment #751506 - Flags: approval-gaia-v1?
Comment on attachment 751506 [details]
Pull Request #9867 - Fix 'day' header behaviour

Adding verifyme for qa verification here once this lands.
Attachment #751506 - Flags: approval-gaia-v1? → approval-gaia-v1+
Keywords: verifyme
Uplifted 50cec689e9c894937d51dd37c6c22defcf2dce40 to:
v1-train: 41e2a22b7efb1f98c910115b2a106fa47e858c3b
status-b2g18: --- → fixed
(Reporter)

Comment 8

6 years ago
As discussed in San Diego work week marking this as leo+.
blocking-b2g: - → leo+
Whiteboard: [TD-25245] → [TD-25245], MiniWW
Flags: in-moztrap?
Flags: in-moztrap? → in-moztrap+
QA Contact: croesch

Comment 9

6 years ago
The "Day" indicator is display normally when selecting the Missed call tab and does not disappear

Build ID: 20130722070207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/68fb0a2e0114
Gaia: 41d10fb10be6916e6554eb440d9a97130ef23ce0
Platform Version: 18.1
status-b2g18: fixed → verified

Comment 10

5 years ago
Deleting "verifyme" per comment 9

Updated

5 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.