If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Buri][IOT]When dialing an MSISDN in dialer, no search is done against Native Agenda until user presses “Dial” button

RESOLVED DUPLICATE of bug 870268

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 870268
4 years ago
4 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Chile, IOT, buri)

(Reporter)

Description

4 years ago
AU_LINUX_GECKO_ICS_STRAWEBRRY_V1.01.00.01.019.094
 Firefox os  v1.0.1
 Mozilla build ID:20130502070201
 
 +++ This bug was initially created as a clone of Bug #451191 +++
 
 DEFECT DESCRIPTION:
 
 When dialing an MSISDN in dialer, no search is done against Native Agenda
 until user presses “Dial” button 
 
 No match is done by DUT while dialing, only after “dial” button is pressed
 and we go into the call progress window the contact name is displayed. 
 
 When you start dialing an MSISDN fron DUt’s dialer and this same MSISDN
 corresponds to a contact in DUT’s native addressbook, dialer does not search
 and show you the matching results while dialing to make it easier for end user
 to complete the dialed number.
 
 
  REPRODUCING PROCEDURES:
 
 "Have a contact with MSISDN 74313. Start dialing from dialer 7–4-3–1-3
 waiting 2 or 3 secods between each digit."
 
 
  EXPECTED BEHAVIOUR:
 
   Match(es) against DUT Native addressbook are shown while dialling. 
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
 
 ++++++++++ end of initial bug #451191 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:

Updated

4 years ago
blocking-b2g: --- → tef?

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 870268
blocking-b2g: tef? → ---
Blocks: 868953

Updated

4 years ago
Blocks: 869681

Updated

4 years ago
Whiteboard: Poland, IOT, Buri
Whiteboard: Poland, IOT, Buri → Chile, IOT, buri
No longer blocks: 869681
You need to log in before you can comment on or make changes to this bug.