All users were logged out of Bugzilla on October 13th, 2018

Forwarding mail received as part of a multipart/mixed mail (e.g. mailman moderation)

NEW
Unassigned

Status

6 years ago
2 years ago

People

(Reporter: mergl, Unassigned)

Tracking

SeaMonkey 2.17 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupeme)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0 SeaMonkey/2.17.1
Build ID: 20130410210803

Steps to reproduce:

I got a mail from my mailman server for moderation. It is set up as a multipart/mixed mail containing the following parts:
1) Moderation request (Content-Type: text/plain)
2) The mail in question (Content-Type: message/rfc822 with any Content-Type)
3) Confirmation aid (Content-Type: message/rfc822 with Content-Type: text/plain)


Actual results:

I select the second part listed in the attachments and double klick on it to open it in a separate window. In this window neither 'Forward' nor 'Reply' is functioning.


Expected results:

Both 'Forward' and 'Reply' should function. (Mainly I want to forward the message or ask the sender for additional info.)
This bug is appeared in 2.17. Before it worked fine.

Comment 1

6 years ago
Please, export this file to eml and attach to this bug

Comment 2

6 years ago
It's not the message format, it's a problem with using forward/reply from a stand-alone message window opened from a message attachment, which indeed doesn't work.

This was fixed in Thunderbird but not in SeaMonkey, there should be a bug pending for this to dupe this one to...

Comment 3

6 years ago
There is MailNews Core bug 204350 - Attached email message window glitches (forward, reply, view source disabled) - which is marked as fixed; and SeaMonkey bug 241213 - Message window for .EML file needs working commands - which is still open.

I don't know if the latter is the exact dupe as it's talking about .EML files opened from a file, but the situation may be identical here (attachments are in essence treated as files).
Whiteboard: dupeme
(Reporter)

Comment 4

6 years ago
This is the point, what rsx11m wrote:

> It's not the message format, it's a problem with using forward/reply from a
> stand-alone message window opened from a message attachment, which indeed
> doesn't work.

Do you really need the mail saved as .EML file?

Comment 5

6 years ago
No, Reply and Forward won't work for me with any message attachment opened in a stand-alone message window. My point was that there may not be much difference between opening a message from a file vs. opening it from a message, given that the inner working appears to be the same for either case.

On the other hand, reading bug 241213, there may be subtle difference between the two cases, thus let's check with Ian whether or not it should be duped.
Flags: needinfo?(iann_bugzilla)

Updated

6 years ago
Duplicate of this bug: 873387

Comment 7

6 years ago
Since both reporters state that it worked for them in earlier versions, this doesn't look like a duplicate of bug 241213 to me (but sure may be related)...

Comment 8

6 years ago
I think, when you open an email as attachment, it is the equivalent of saving the attachment to a temporary area and then opening it, so should probably be marked as a duplicate but the summary of the bug 241213 will need adjusting to capture both.
Flags: needinfo?(iann_bugzilla)
(Reporter)

Comment 9

4 years ago
Hi there,

this problem still exists in the latest version [Mozilla/5.0 (X11; Linux i686; rv:36.0) Gecko/20100101 Firefox/36.0 SeaMonkey/2.33.1] though it was corrected in Thunderbird 24! :-(

Can't it be merged in?

Comment 10

2 years ago
The problem remains in Seamonkey version 2.40 over Windows 7 Pro x64 referenced as:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0 SeaMonkey/2.40

It persists in night-build version seamonkey-2.49a1.en-US.win32.zip in same environ.

It's fixed in Thunderbird 45.5.1 (and probably in previous versions) in same environ.

In all cases, only checked opening EML files directly from file system: Seamonkey opens and show them correctly, but clicking REPLY/REPLY ALL/FORWARD buttons does nothing.

Regards and good job.

Comment 11

2 years ago
the problem that Reply/Reply All/Forward is still not working when opening a forwarded message as attachment still remains.

I just tried it with a new profile, write an e-mail, forward this e-mail, open the first e-mail within  the forwarded e-mail, try to Reply/Reply All/Forward this message in the new message window -- nothing happens.

User agent: Mozilla/5.0 (X11; Linux i686; rv:49.0) Gecko/20100101 Firefox/49.0 SeaMonkey/2.46
Build identifier: 20161213180120

Comment 12

2 years ago
20161213180120
Mozilla/5.0 (X11; Linux i686; rv:49.0) Gecko/20100101 Firefox/49.0 SeaMonkey/2.46
Linux 3.16.0-4-686-pae
Status: UNCONFIRMED → NEW
Ever confirmed: true
You need to log in before you can comment on or make changes to this bug.