Closed Bug 870316 Opened 7 years ago Closed 7 years ago

[regression] Vibration icon disappears on statusbar and lockscreen in gaia master

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: alive, Assigned: alive)

References

Details

(Whiteboard: visual design, visual-tracking)

Attachments

(2 files)

STR:

Use volume rocker to enable vibration mode.

Expected:
Vibration icon on statusbar and lockscreen.

Acutal:
No any vibration icon.

Note:
And no any mute icon if you press 'silent incoming call' in the device menu too.
Because vibration class is still there. Will be fixed by 867912.

*Is this on intentional?*

+++ This bug was initially created as a clone of Bug #863710 +++

The patch needs some love, mostly about transparent icons.

In addition the patch will solve an usability issue where there is no clock on the statusbar while you're doing a phone call.

Josh feel free to have someone taking this patch to add the missing icons if that can help to go faster.
Hey Peter, is this intentional?
Flags: needinfo?(pla)
Whiteboard: visual design, u=user c=lock s=ux-most-wanted → visual design, visual-tracking
Hey Eric,

As far as I know, we were never asked to do these icons for the status bar.  It probably slipped through the cracks somewhere.  If they need them, let's create them.  I would ask for a complete list of missing icons to make sure we've covered everything.
Flags: needinfo?(pla)
Hi,
Can you send us a complete list of any missing icons?  We can take a look and see why they are missing of if they need to be created.  Thanks!
Flags: needinfo?(alive)
Attached image Vibrate Icon
Peter, I was able to find this vibrate Icon.  I added it to the current status bar sprite on box.  But i don't think we designed it...Once we have a list of anything missing we can revisit this. Thanks!
Flags: needinfo?(pla)
Assignee: nobody → alive
Attachment #760792 - Flags: review?(timdream)
Attachment #760792 - Flags: review?(timdream) → review+
https://github.com/mozilla-b2g/gaia/commit/02ca08eb9c89f3e200fedce04c4f4ea5dad84652
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Hey Eric,

That one looks like ours.  It's the one I designed for the Volume notification toast.  Ok, let me know if there are more icons to be covered when you find out.  Thanks Eric.
Flags: needinfo?(pla)
You need to log in before you can comment on or make changes to this bug.