[Lockscreen] Secure Camera doesn't work after second time launch

RESOLVED DUPLICATE of bug 871472

Status

Firefox OS
Gaia::System::Lockscreen
RESOLVED DUPLICATE of bug 871472
5 years ago
5 years ago

People

(Reporter: alive, Assigned: gduan.moz)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

STR:

1. Set passcode in settings->phonelock
2. Turn off screen
3. Turn on screen
4. Launch camera on lockscreen
5. Press home
6. Launch camera on lockscreen

Expected:
Camera works fine.

Actual:
Black view in camera.

Note:
Looks like the secure camera isn't remove from dom tree when home button is pressed.

Updated

5 years ago
blocking-b2g: leo? → leo+

Comment 1

5 years ago
(In reply to Alive Kuo [:alive] from comment #0)
> STR:
> 
> 1. Set passcode in settings->phonelock
> 2. Turn off screen
> 3. Turn on screen
> 4. Launch camera on lockscreen
> 5. Press home
> 6. Launch camera on lockscreen
> 
> Expected:
> Camera works fine.
> 
> Actual:
> Black view in camera.
> 
> Note:
> Looks like the secure camera isn't remove from dom tree when home button is
> pressed.

Alive, what device and builds are you testing on?
Is this a regression?  Still reproducing?
Flags: needinfo?(alive)
Whiteboard: qawanted
Keywords: qawanted
Whiteboard: qawanted

Comment 3

5 years ago
Issue is still reproducing on:

Inari Build ID: 20130515070208
Commercial RIL
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/d06cfe7d67c2
Gaia: 0ddb515f15cbc6b74fc2742b7599d6ae74c6413f
Keywords: qawanted
Deassign myself.
Assignee: alive → nobody
Flags: needinfo?(alive)
Assignee: nobody → yurenju.mozilla
Geogre will help on this.
Assignee: yurenju.mozilla → gduan.moz
(Assignee)

Comment 6

5 years ago
already resolved in #871472.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 871472
You need to log in before you can comment on or make changes to this bug.