Closed Bug 870339 Opened 7 years ago Closed 6 years ago

Intermittent browser/devtools/styleeditor/test/browser_styleeditor_bug_740541_iframes.js | UI elements present - Got 24, expected 12

Categories

(DevTools :: Style Editor, defect)

x86_64
Linux
defect
Not set

Tracking

(firefox24 fixed, firefox25 fixed, firefox26 fixed)

RESOLVED FIXED
Firefox 26
Tracking Status
firefox24 --- fixed
firefox25 --- fixed
firefox26 --- fixed

People

(Reporter: RyanVM, Assigned: dcrewi)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=22762827&tree=Mozilla-Central

Rev3 Fedora 12x64 mozilla-central debug test mochitest-browser-chrome on 2013-05-08 22:32:46 PDT for push dea5219d6b43
slave: talos-r3-fed64-058

23:12:34     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/styleeditor/test/browser_styleeditor_bug_740541_iframes.js | all style sheets loaded
23:12:34  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/styleeditor/test/browser_styleeditor_bug_740541_iframes.js | UI elements present - Got 24, expected 12
23:12:34     INFO -  Stack trace:
23:12:34     INFO -      JS frame :: chrome://mochikit/content/browser-test.js :: test_is :: line 527
23:12:34     INFO -      JS frame :: chrome://mochitests/content/browser/browser/devtools/styleeditor/test/browser_styleeditor_bug_740541_iframes.js :: <TOP_LEVEL> :: line 84
23:12:34     INFO -      JS frame :: resource:///modules/devtools/shared/event-emitter.js :: EventEmitter_emit :: line 107
23:12:34     INFO -      JS frame :: resource://app/modules/devtools/StyleEditorUI.jsm :: <TOP_LEVEL> :: line 288
23:12:34     INFO -      JS frame :: resource://app/modules/devtools/SplitView.jsm :: <TOP_LEVEL> :: line 210
23:12:34     INFO -      native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
23:12:34     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/styleeditor/test/browser_styleeditor_bug_740541_iframes.js | Console message: [JavaScript Warning: "Error in parsing value for '-moz-box-ordinal-group'.  Declaration dropped." {file: "chrome://browser/content/devtools/styleeditor.xul" line: 0 column: 0 source: "-1"}]
23:12:34     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/styleeditor/test/browser_styleeditor_bug_740541_iframes.js | Console message: [JavaScript Warning: "Error in parsing value for '-moz-box-ordinal-group'.  Declaration dropped." {file: "chrome://browser/content/devtools/styleeditor.xul" line: 0 column: 0 source: "-1"}]
23:12:34     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/styleeditor/test/browser_styleeditor_bug_740541_iframes.js | Console message: [JavaScript Warning: "XUL box for h3 element contained an inline #text child, forcing all its children to be wrapped in a block." {file: "chrome://browser/content/devtools/styleeditor.xul" line: 0}]
23:12:34     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/styleeditor/test/browser_styleeditor_bug_740541_iframes.js | Console message: [JavaScript Warning: "Error in parsing value for '-moz-box-ordinal-group'.  Declaration dropped." {file: "chrome://browser/content/devtools/styleeditor.xul" line: 0 column: 0 source: "-1"}]
23:12:34     INFO -  WARNING: NS_ENSURE_TRUE(mMutable) failed: file ../../../../netwerk/base/src/nsSimpleURI.cpp, line 265
23:12:34     INFO -  INFO TEST-END | chrome://mochitests/content/browser/browser/devtools/styleeditor/test/browser_styleeditor_bug_740541_iframes.js | finished in 1829ms
David, can you please look into this or suggest someone who can? :)
Flags: needinfo?(dcrewi)
Attached patch patch v1Splinter Review
I have no idea why StyleEditorDebuggee is sometimes getting multiple calls to _onNewDocument, but things should ideally be robust enough to handle it in any case.
Attachment #792297 - Flags: review?(fayearthur)
Flags: needinfo?(dcrewi)
Comment on attachment 792297 [details] [diff] [review]
patch v1

Review of attachment 792297 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks a bunch for looking at this David. This looks good. The page load logic in the Style Editor really needs to be refactored /:

Try run here:

https://tbpl.mozilla.org/?tree=Try&rev=2985bee085da
Attachment #792297 - Flags: review?(fayearthur) → review+
Assignee: nobody → dcrewi
Whiteboard: [land-in-fx-team]
https://hg.mozilla.org/integration/fx-team/rev/e92bf45c6b0b
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/e92bf45c6b0b
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 26
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.