do not output error messages from reboot step on android

RESOLVED FIXED

Status

Release Engineering
General Automation
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: jmaher, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
I have noticed a lot of the failures that we see starred related to android seem to be in the reboot step.  My assertion is that we do not care about these errors and the related starring of bugs provide no benefit.

Please present any information that I might not be aware of.  

Doing this will remove most if not all double starring that occurs on the nss shutdown crash we experience.  It will also help us focus on issues related to setting up and running tests.

Comment 1

5 years ago
I agree that it would be good to get rid of the error line if it isn't the root cause in many causes. 

That said, I've found some runs where no other failure line is present - am I correct in thinking the "java.lang.IllegalArgumentException" / "WIN DEATH" pattern in these is the real cause? If so, we should add it to the TBPL parser or else (preferably) add support for it in mozcrash or remoteautomation.py

https://tbpl.mozilla.org/php/getParsedLog.php?id=22724423&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=22723294&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=22721902&tree=Mozilla-Inbound
Blocks: 822321
(Reporter)

Comment 2

5 years ago
Created attachment 748102 [details] [diff] [review]
silence the errors from sut_tool/* dm* while doing a reboot (1.0)

not tested in a production like environment, would like to get some testing in staging before deploying.
Attachment #748102 - Flags: review?(bugspam.Callek)
Comment on attachment 748102 [details] [diff] [review]
silence the errors from sut_tool/* dm* while doing a reboot (1.0)

Review of attachment 748102 [details] [diff] [review]:
-----------------------------------------------------------------

::: sut_tools/sut_lib.py
@@ +443,2 @@
>      log.info(flagfile)
> +    if contents is not None and not silent:

r-, I want the actual flag to be set here, so we can bail if the device goes bad. the silent should only be for the print below.
Attachment #748102 - Flags: review?(bugspam.Callek) → review-
(Reporter)

Comment 4

5 years ago
Created attachment 748153 [details] [diff] [review]
silence the errors from sut_tool/* dm* while doing a reboot (1.1)

got it!
Attachment #748102 - Attachment is obsolete: true
Attachment #748153 - Flags: review?(bugspam.Callek)
Comment on attachment 748153 [details] [diff] [review]
silence the errors from sut_tool/* dm* while doing a reboot (1.1)

Review of attachment 748153 [details] [diff] [review]:
-----------------------------------------------------------------

land away we'll test this Monday
Attachment #748153 - Flags: review?(bugspam.Callek) → review+
Comment on attachment 748153 [details] [diff] [review]
silence the errors from sut_tool/* dm* while doing a reboot (1.1)

Review of attachment 748153 [details] [diff] [review]:
-----------------------------------------------------------------

::: sut_tools/sut_lib.py
@@ +548,4 @@
>      attempt = 0
>      while attempt < max_attempts:
>          attempt += 1
> +        retVal = soft_reboot(device, dm, *args, silent, **kwargs)

Inconsistent order of arguments here. Should be ..., dm, silent, *args, ...
(Reporter)

Comment 7

5 years ago
checked in as well as flipping arguments from comment #6 (thanks :gbrown):
http://hg.mozilla.org/build/talos/rev/66e1bfa39d3f
This looked good in staging, and since we had to do a deploy today for another reason I went ahead and made this live.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

5 years ago
Created attachment 749809 [details] [diff] [review]
fix typo we overlooked and didn't see in staging (1.0)
Attachment #749809 - Flags: review?(bugspam.Callek)

Updated

5 years ago
Attachment #749809 - Flags: review?(bugspam.Callek) → review+
(Reporter)

Comment 10

5 years ago
landed:
https://hg.mozilla.org/build/tools/rev/d6b3ac0de002

please deploy when you get a chance.
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.