Group duplicated entries

RESOLVED WONTFIX

Status

Toolkit Graveyard
Error Console
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: sjw, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 747548 [details]
layout example

It would be very helpful if you could group duplicated entries (entries, that have the same warning) in the error console. The grouped entries should be shown on top and you should be able to show them all if you open the group (eg by click).

See attachment for details.
(Reporter)

Updated

5 years ago
Blocks: 490886

Comment 1

5 years ago
Firefox DevTools webconsole groups duplicated entries and then uses a badge with the count of duplicated entries. You can look at the code there to see if it can be adapted for the Toolkit Error Console.
(Reporter)

Comment 2

5 years ago
That's not exactly what I mean, but could you show me how I can do this?
(Reporter)

Updated

5 years ago
Blocks: 778766

Updated

5 years ago
No longer blocks: 778766
(Reporter)

Updated

4 years ago
Component: Error Console → Developer Tools: Console
Product: Toolkit → Firefox
(Reporter)

Updated

4 years ago
Summary: group duplicated entries → group similar entries

Comment 3

4 years ago
Please don't repurpose existing Error Console bugs. Instead you should file new bugs under devtools. TIA.
Status: UNCONFIRMED → NEW
Component: Developer Tools: Console → Error Console
Ever confirmed: true
Product: Firefox → Toolkit
Summary: group similar entries → Group duplicated entries
Version: unspecified → Trunk
The Error Console has been removed in favor of the Browser Console (see Bug 1278368), and the component is going to be removed.  If this bug is also relevant in the Browser Console, please reopen and move this into Firefox -> Developer Tools: Console.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
I am mass-reopening and re-componenting every single one of the Toolkit:Error Console bugs that appear to have been closed without anyone even *glancing* at whether they were relevant to the Browser Console.

If you want to close a whole bunch of old bugs -- FOR ANY REASON -- it is YOUR RESPONSIBILITY to check EVERY SINGLE ONE OF THEM and make sure they are no longer valid.  Do not push that work onto the bug reporters.

(It's okay to close bugs that haven't been touched in years when they don't have enough information for you to figure out whether the problem is still relevant to the current software - the reporter probably isn't coming back to clarify.  But that is the ONLY situation where it is okay.)

(I'm going to have to do this in two steps because of the way the "change several bugs at once" form works.  Apologies for the extra bugspam.)
Status: RESOLVED → REOPENED
Component: Error Console → Developer Tools: Console
Product: Toolkit → Firefox
Resolution: WONTFIX → ---
The Error Console feature was removed entirely from the tree in Bug 1278368 and the bugzilla component is now being removed. We’ve migrated bugs that seem to also affect the Browser Console into the devtools component, please move this over if it was missed.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Component: Developer Tools: Console → Error Console
Product: Firefox → Toolkit
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.