HTML-Entity converter

VERIFIED FIXED in Future

Status

()

Core
Editor
P4
enhancement
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: GavinBrelstaff, Assigned: rubydoo123)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [RFE])

(Reporter)

Description

17 years ago
Feature request:
A format - paragraph option to auto-convert accented characters (etc)
into HTML entities such as è for the "e grave" character
available on many european keyboards.
Otherwise, other web browser might misinterpret the character and display
incorrect text or even an error message.
The code for this is already in the public-domain as a part of
HTML-TIDY avaialable at:

http://www.w3.org/People/Raggett/tidy/

It would be nice to have the inverse conversion too.
Composer already saves รจ as è. ISO-Latin1 chars are encoded using
mnemonic entities. Other chars are saved using decimal numeric references.
However, this is not reflected in the source view.

If this bug is about saving the file, I think this bug is invalid.

If this bug is about showing the entity references in the source view exactly as
they get written to disk, then this bug needs resummarizing.
(Assignee)

Comment 2

17 years ago
moving to future and adding keywords
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P4
Whiteboard: [RFE]
Target Milestone: --- → Future

Comment 3

17 years ago
what is the bug here?
(Reporter)

Comment 4

17 years ago
Forget this feature request!
 - the functionality is already in Editor.
Accents get converted to text when you save to file.
The HTML source view is slightly misleading because
it doesn't show the HTML-entity versions. But I'm
not complaining since the result is a lot more readable.
Well done guys
 
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 5

17 years ago
Gavin, please mark this VERIFIED-FIXED if you can...thanks...
(Reporter)

Comment 6

17 years ago
Verifying as requested
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.