Windows jumplist not showing anymore

VERIFIED FIXED in Firefox 22

Status

()

Firefox
Shell Integration
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: ge3k0s, Assigned: bbondy)

Tracking

Trunk
Firefox 24
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox21 wontfix, firefox22+ verified, firefox23+ verified, firefox24+ verified)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
In recent Nightly and UX builds I can't see the jumplist (open new tab/new window/private window+ recent history items) anymore. I've tried on several configs and it's still not showing.
Can you try with a clean profile? I can see the jumplist on my Nightly by right-clicking on the app in the taskbar.
(Reporter)

Comment 2

5 years ago
I've tried on two computers with clean profiles (in fact my current config has completely reinstalled today) and I still don't see it. Maybe it's related to the fact that I use Jamun as default config.
Reproducible on FF 21-23 if Firefox is located in a non-default installation folder.
Status: UNCONFIRMED → NEW
Component: Menus → Shell Integration
Ever confirmed: true
Repro on FF 4.0.1 if renaming the folder after install.
(In reply to Paul Silaghi [QA] from comment #3)
> Reproducible on FF 21-23 if Firefox is located in a non-default installation
> folder.

Does this reproduce on Firefox 20 or earlier with Firefox installed to a custom folder?
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #5)
> Does this reproduce on Firefox 20 or earlier with Firefox installed to a
> custom folder?

Basically yes, but it seems to be somehow intermittent and I couldn't manage to find the regression range. I'm no longer convinced that only the default installation folder is the problem. According to bug 609443, bug 598229, there is a delay until the jump list is created.
What's for sure is that installing nightly 23.0a1 (2013-05-13) in a custom folder, will make the jumplist show only 3 options: nightly, pin this program to taskbar and close window.
Let's see if anyone from bug 598229 has any ideas.
Blocks: 598229
(In reply to Paul Silaghi [QA] from comment #4)
> Repro on FF 4.0.1 if renaming the folder after install.
This would be another issue. If renaming the installation folder no jumplist at all will be displayed.
Anthony, do you think worth filing a bug considering this scenario?
I'm not sure, I need someone familiar with the installation code to comment as to whether any of this is expected or not. CCing Robert Strong who may have more input.
(In reply to Paul Silaghi [QA] from comment #7)
> (In reply to Paul Silaghi [QA] from comment #4)
> > Repro on FF 4.0.1 if renaming the folder after install.
> This would be another issue. If renaming the installation folder no jumplist
> at all will be displayed.
> Anthony, do you think worth filing a bug considering this scenario?
Not worth it and not a supported modification for multiple reasons (e.g. this can also break uninstall from Programs and Features for example). Since we support multiple installs the directory is used by the jumplist code to determine which install the task bar jumplist is for.

Comment 10

5 years ago
I'm having this same problem on a recently set-up computer - no jumplist at all on Firefox pinned to Start Menu.

Running Firefox Beta v22.0 on Windows 7 64-bit

Comment 11

5 years ago
I confirm. Jump list lost if FF 21 installed (previous version uninstalled first) to custom folder (%programfiles%\firefox).
FF 20, as I know, do not have this bug.
1. Install Firefox 20.0 to C:\Program Files\firefox\
2. Start Firefox and check the jumplist
> Jumplist contains 3 items:
> * Firefox
> * Unpin
> * Close Window
3. Uninstall Firefox 20.0 through Control Panel, opting to keep the profile folder intact
4. Install Firefox 21.0 to C:\Program Files\firefox\
5. Start Firefox and check the jumplist
> Jumplist contains the same three items
6. Uninstall Firefox 21.0 through Control Panel, opting to keep the profile folder intact
7. Install Firefox 21.0 using the default settings
8. Start Firefox and check the jumplist
> Jumplist contains the same three items

To whomever can reproduce this can you please provide specific steps to reproduce and details results of what you see and what you expect to see? That way Robert can determine if this is a bug or if it's working as we intended.
Duplicate of this bug: 874564
Duplicate of this bug: 874329
Jim / Brian, could one of you look into this bug? Thanks!
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #12)
> 1. Install Firefox 20.0 to C:\Program Files\firefox\
> 2. Start Firefox and check the jumplist
> > Jumplist contains 3 items:
> > * Firefox
> > * Unpin
> > * Close Window
This is the problem - jumplist should contain more options (new tab, new window, new private window and parts of history)

Comment 17

5 years ago
Steps to Reproduce:
1. Extract m-c zip into a folder
2. Start browser with a extant profile
3. Wait for few minutes(at least 3 minutes)
4. Right click on taskbar button

Actual Results:
Jumplist contains only 3 items

Expected Results:
Jump list should pop up (incl. Frequent urls, Open new tab, Open new window, New private window)



Regression window(m-aurora)
Good:
http://hg.mozilla.org/releases/mozilla-aurora/rev/8c16af22324b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20130219 Firefox/20.0 ID:20130219071728
Bad:
http://hg.mozilla.org/releases/mozilla-aurora/rev/d8c97bae8521
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130219 Firefox/21.0 ID:20130219104339
Pushlog:
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=8c16af22324b&tochange=d8c97bae8521



Regression window(m-central)
Good:
http://hg.mozilla.org/mozilla-central/rev/729fe49f9e1f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130211 Firefox/21.0 ID:20130211044914
Bad:
http://hg.mozilla.org/mozilla-central/rev/784b9beebe90
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130211 Firefox/21.0 ID:20130211052314
Pushlog;
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=729fe49f9e1f&tochange=784b9beebe90

Comment 18

5 years ago
Mike Hommey — Bug 755724 - Move browser application in a subdirectory. r=jimm

Is it the regression?

Comment 19

5 years ago
(In reply to Alice0775 White from comment #17)
> Steps to Reproduce:
> 1. Extract m-c zip into a folder
> 2. Start browser with a extant profile
> 3. Wait for few minutes(at least 3 minutes)
> 4. Right click on taskbar button

Interesting, I'm surprised this scenario worked in the past since there's no task bar id stored in the registry (via the installer). In this case we fall back on whatever Windows does internally to identify the app, which is probably pretty unpredictable in these complex multi-install scenarios.

(In reply to Loic from comment #18)
> Mike Hommey — Bug 755724 - Move browser application in a subdirectory. r=jimm
> 
> Is it the regression?

That was a big file installation layout change, although I'm surprised it affected jump lists.

Comment 20

5 years ago
Do any of you have the pref 'taskbar.grouping.useprofile' set?

Updated

5 years ago
(Assignee)

Updated

5 years ago
Assignee: nobody → netzen
(Assignee)

Comment 21

5 years ago
Created attachment 752868 [details] [diff] [review]
Patch v1.

browser's delayed startup finished notification kicks off nsBrowserGlue.js's observer which tries to startup the jump list. 
This would normally call shell svc's shortcutMaintenance which calls into helper.exe to create the TaskBarIDs entry.

But resource:///modules/WindowsJumpLists.jsm was never created because it had the wrong path.
Attachment #752868 - Flags: review?(jmathies)

Comment 22

5 years ago
I have this issue too.

When I upgraded (installed new over the existing) FF 20 to 21 the issue didn't occur, the extra jump list items were there, it only occurred when I performed a clean install of FF 21.

I'm installing FF to the default installation folder as administrator with UAC enabled.

I also tried installing FF 21 (clean) in a VM, same.

Windows 7 x86

Updated

5 years ago
Attachment #752868 - Flags: review?(jmathies) → review+

Updated

5 years ago
Blocks: 755724

Updated

5 years ago
Duplicate of this bug: 847189
(Assignee)

Comment 24

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/01d3f80565cc
tracking-firefox22: --- → ?
tracking-firefox23: --- → ?
Target Milestone: --- → Firefox 24
Funny story: while you weren't working (or maybe forever, I don't actually know), RasterImage.cpp:1753 developed an aversion and an assertion, NS_IsMainThread(), about off-main-thread mucking about with images, which according to

https://tbpl.mozilla.org/php/getParsedLog.php?id=23296853&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=23297625&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=23296999&tree=Mozilla-Inbound

you hit when that URI is fixed so that you actually work.

Backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/ba0c364be016
(Assignee)

Comment 26

5 years ago
Seems like bug 716140 would have introduced this regression had jump lists been working.
Depends on: 716140
(Assignee)

Comment 27

5 years ago
Hi Joe, 

Do you have any recommendations/guidance on fixing this?
It seems like the multi threaded decoding work made it so off the main thread decoding no longer works.
Flags: needinfo?(joe)
(Assignee)

Comment 28

5 years ago
I think this breaks all jump lists by the way, it's just that if a jump list was previously generated for the taskbar icon's app user model ID it will continue to display. (Hence the tracking flags)
status-firefox21: --- → affected
status-firefox22: --- → affected
status-firefox23: --- → affected
status-firefox24: --- → affected
tracking-firefox22: ? → +
tracking-firefox23: ? → +
tracking-firefox24: --- → +
My suggestion: send an event to the main thread to start the decoding of images. You can't decode images off the main thread unless you're Imagelib itself.
Flags: needinfo?(joe)
(Assignee)

Updated

5 years ago
Depends on: 875609
(Assignee)

Comment 30

5 years ago
We could before bug 716140 :S
Posted bug 875609 to refactor the jump list code that will need to be fixed before we can re-land this. bug 716140 looks really big so I don't think it can be easily backed out.

Thanks for the info Joe.
(In reply to Brian R. Bondy [:bbondy] from comment #30)
> We could before bug 716140 :S

Only by accident - imagelib's threading was always very clear as to what's allowed off the main thread; we just didn't assert it before :)
(Assignee)

Comment 32

5 years ago
But it did work, other than a fix we made several months ago to discard tracker.
(Assignee)

Comment 33

5 years ago
Just kind of a pain for this code because we have to write to disk off the main thread, so that means we have to decode on the main thread, keep it all in a buffer and then pass the buffer to the other thread to write to disk. Hopefully there are no large manually crafted favicons.

Comment 34

5 years ago
My jumplist shows only 3 items: Mozilla Firefox, unpin from Taskbar and close window. The tasks (new window, new private window, new tab) and the Frequently visited sites are missing.

Steps to reproduce:
1) Remove Firefox from your computer completely, deleting all preferences and bookmarks also.
2) Do a fresh installation of Firefox 21.0 (I have the Dutch language version)

I have Windows 7 64-bits installed.

I see that the target milestone for this bug is Firefox 24. Does this mean I have to wait several months for this to be fixed? What is the status of this bug?

Comment 35

5 years ago
I've tried removing Firefox 21.0 from my system and installing Firefox 20.0. This does not fix the jumplist, the tasks and frequently visited categories remain missing.

I then tried removing Firefox from my system and installing the very old Firefox 10.0. This also does not fix the jumplist, the tasks and frequently visited categories remain missing.

Not knowing what to do, I reinstalled Firefox 21.0. So now I'm stuck with Firefox 21.0 without a working jumplist. Is there no way for me to work around this bug?
(Assignee)

Comment 36

5 years ago
I think you could try Firefox 20. I'm not sure what version jumplists were introduced in so I'm not sure if Firefox 10 would have it.  It takes some time to generate though so it won't show up right away.  I'm going to try and get this uplifted though so it should be in Firefox 22.  That would be on or around June 24th.

Comment 37

5 years ago
(In reply to dusty-2011 from comment #35)
> I then tried removing Firefox from my system and installing the very old
> Firefox 10.0. This also does not fix the jumplist, the tasks and frequently
> visited categories remain missing.
What worked for me was deleting the jumplist data so Windows rebuilds it, I've had to do that before when this bug first showed up in the nighty builds a couple months back and I downgraded.  Unpin Firefox from the taskbar and start menu, then search for files containing firefox.exe in "%APPDATA%\Microsoft\Windows\Recent\AutomaticDestinations" and "%APPDATA%\Microsoft\Windows\Recent\CustomDestinations", should have names like "969252ce11249fdd.customDestinations-ms".  Use care of course.

Comment 38

5 years ago
(In reply to Jen Smith from comment #37)
> (In reply to dusty-2011 from comment #35)
> > I then tried removing Firefox from my system and installing the very old
> > Firefox 10.0. This also does not fix the jumplist, the tasks and frequently
> > visited categories remain missing.
> What worked for me was deleting the jumplist data so Windows rebuilds it,
> I've had to do that before when this bug first showed up in the nighty
> builds a couple months back and I downgraded.  Unpin Firefox from the
> taskbar and start menu, then search for files containing firefox.exe in
> "%APPDATA%\Microsoft\Windows\Recent\AutomaticDestinations" and
> "%APPDATA%\Microsoft\Windows\Recent\CustomDestinations", should have names
> like "969252ce11249fdd.customDestinations-ms".  Use care of course.

I tried this. I took the following steps:
1) Unpin Firefox from task bar and start menu
2) Uninstall Firefox 21.0
3) Delete all files in "%APPDATA%\Microsoft\Windows\Recent\AutomaticDestinations" and "%APPDATA%\Microsoft\Windows\Recent\CustomDestinations"
4) Install Firefox 20.0.1

It did not work. I still have a missing jumplist for Firefox. Both the tasks section and the frequently visited section are still missing.

Are there any other things I could try?
(Assignee)

Comment 39

5 years ago
dusty-2011, let's wait until this lands on Nightly and then you can try a Nightly Firefox build to see if it works.

Comment 40

5 years ago
Jumplist still missing in Nightly both Firefox 20.1 and21 22
(Assignee)

Comment 41

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/16871058c21a
https://hg.mozilla.org/mozilla-central/rev/16871058c21a
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-firefox24: affected → fixed
Resolution: --- → FIXED
(Assignee)

Comment 43

5 years ago
Comment on attachment 752868 [details] [diff] [review]
Patch v1.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 755724
User impact if declined: Windows 7+ jump lists on the taskbar will not work if not previously generated or if icon re-created.
Testing completed (on m-c, etc.): I will verify this on m-c before uplifting.
Risk to taking this patch (and alternatives if risky): Low
String or IDL/UUID changes made by this patch: None
Attachment #752868 - Flags: approval-mozilla-beta?
Attachment #752868 - Flags: approval-mozilla-aurora?

Comment 44

5 years ago
Is this supposed to be fixed in the current Nightly release? I have the current Nightly release installed [24.0a1 (2013-05-30)] and my jumplist is the same as with Firefox 21, the tasks section and the frequently visited section are both missing.

I checked for non-default values in the following settings, but they are all at the default value:
browser.taskbar.lists.enabled default: true
browser.taskbar.lists.frequent.enabled default: true
browser.taskbar.lists.recent.enabled default: false
browser.taskbar.lists.tasks.enabled default: true
browser.taskbar.lists.maxListItemCount default: 7 

My jumplist does work on all other programs. It works on Internet Explorer, Crhome, Excel, Word, Adobe Reader, etc. Both in Internet Explorer and in Chrome I have the tasks section and the frequently visited section.
(In reply to dusty-2011 from comment #44)
> Is this supposed to be fixed in the current Nightly release? <snip>
No, it just landed in comment #42 and will be in tomorrow's nightly

Comment 46

5 years ago
Just updated my copy of Nightly and the jumplists are working again.  :)   Is this going to filter back into the stable v21 release, or is it v24 and forward?
(Assignee)

Comment 47

5 years ago
Hopefully v22 and onward (June 24th).

I requested that it gets moved up to v22, but it's not my call from here.

Comment 48

5 years ago
(In reply to Robert Strong [:rstrong] (do not email) from comment #45)
> (In reply to dusty-2011 from comment #44)
> > Is this supposed to be fixed in the current Nightly release? <snip>
> No, it just landed in comment #42 and will be in tomorrow's nightly

I have today's nightly (31-5) and the jumplist appeared to be not working at first. I was writing on this page that it didn't work, then I tried it one more time, and now it does work. It seems that it takes a while for the jumplist to be generated.

I now have the tasks section and the frequently visited section on my jumplist.

I am however unable to pin a site to my jumplist with the current Nightly!! In firefox 21 I can pin a site to my jumplist by dragging the icon on the left of the address bar to the Firefox icon on the taskbar. This does not work with the current Nightly!! The only way I can pin a site in the current nightly is by clicking on the pin icon next to a frequently visited site. But this means I can only pin a frequently visited site. In firefox 21 I used to be able to pin any site to my taskbar by dragging the icon from the address bar to the taskbar!

So although the status of this bug is "resolved fixed" one part of the jumplist (Pinned sites) is still not working properly!

Comment 49

5 years ago
(In reply to dusty-2011 from comment #48)
> I am however unable to pin a site to my jumplist with the current Nightly!!
> In firefox 21 I can pin a site to my jumplist by dragging the icon on the
> left of the address bar to the Firefox icon on the taskbar. This does not
> work with the current Nightly!! 
Hate to be one of those "well it works for me" types, but it's working for me, Windows 7 x64. Wasn't even aware you could do that, was pinning via the recent section of the jumplist (I have frequent disabled).. convenient.

(In reply to Brian R. Bondy [:bbondy] from comment #47)
> Hopefully v22 and onward (June 24th).
> 
> I requested that it gets moved up to v22, but it's not my call from here.
Thanks
(Assignee)

Comment 50

5 years ago
(In reply to dusty-2011 from comment #48)
> (In reply to Robert Strong [:rstrong] (do not email) from comment #45)
> > (In reply to dusty-2011 from comment #44)
> > > Is this supposed to be fixed in the current Nightly release? <snip>
> > No, it just landed in comment #42 and will be in tomorrow's nightly
> 
> I have today's nightly (31-5) and the jumplist appeared to be not working at
> first. I was writing on this page that it didn't work, then I tried it one
> more time, and now it does work. It seems that it takes a while for the
> jumplist to be generated.

Comment 36 Brian R. Bondy [:bbondy] 2013-05-28 12:37:36 PDT 
" It [the jump list] takes some time to generate though so it won't show up right away. "


> 
> I now have the tasks section and the frequently visited section on my
> jumplist.
> 
> I am however unable to pin a site to my jumplist with the current Nightly!!
> In firefox 21 I can pin a site to my jumplist by dragging the icon on the
> left of the address bar to the Firefox icon on the taskbar. This does not
> work with the current Nightly!! The only way I can pin a site in the current
> nightly is by clicking on the pin icon next to a frequently visited site.
> But this means I can only pin a frequently visited site. In firefox 21 I
> used to be able to pin any site to my taskbar by dragging the icon from the
> address bar to the taskbar!
> 
> So although the status of this bug is "resolved fixed" one part of the
> jumplist (Pinned sites) is still not working properly!

I'm willing to help you investigate this request, but it is outside the scope of the fix in this bug. Please post a new bug and CC me (netzen@gmail.com) and I will help investigate your findings.

Updated

5 years ago
Attachment #752868 - Flags: approval-mozilla-beta?
Attachment #752868 - Flags: approval-mozilla-beta+
Attachment #752868 - Flags: approval-mozilla-aurora?
Attachment #752868 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 51

5 years ago
Please don't land this on mozilla-beta and mozilla-aurora until bug 875609 has landed there.
Comment on attachment 752868 [details] [diff] [review]
Patch v1.

We now see bug 875609, so we're reconsidering landing on beta
Attachment #752868 - Flags: approval-mozilla-beta+ → approval-mozilla-beta?

Comment 53

5 years ago
In Nightly 2013-05-31 Jumplist work again, thanks.

Updated

5 years ago
Depends on: 878449
(Assignee)

Comment 54

4 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/b42fece81a15
status-firefox23: affected → fixed
(In reply to Paul Silaghi [QA] from comment #3)
> Reproducible on FF 21-23 if Firefox is located in a non-default installation
> folder.
The jumplist appeared after ~100sec.
Verified fixed FF 24.0a1 (2013-06-02)
Status: RESOLVED → VERIFIED
status-firefox24: fixed → verified

Updated

4 years ago
Duplicate of this bug: 877067
Verified fixed FF 23.0a2 (2013-06-03)
status-firefox23: fixed → verified
Comment on attachment 752868 [details] [diff] [review]
Patch v1.

Support weighed in - we've gotten complaints about this issue, so approving for FF22. We'll back out if we find any critical regressions in these last three weeks.
Attachment #752868 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Updated

4 years ago
Keywords: qawanted, verifyme
https://hg.mozilla.org/releases/mozilla-beta/rev/da2591d85389
status-firefox21: affected → wontfix
status-firefox22: affected → fixed

Comment 60

4 years ago
(In reply to Alex Keybl [:akeybl] from comment #58)
> We'll back out if we find any critical regressions in these last three weeks.
Already found. See bug 878449.
Verified as fixed on Firefox 22 beta 4:
Mozilla/5.0 (Windows NT 6.1; rv:22.0) Gecko/20100101 Firefox/22.0
Build ID: 20130605070403
status-firefox22: fixed → verified
Keywords: qawanted, verifyme
(Assignee)

Updated

4 years ago
No longer depends on: 878449
(Assignee)

Updated

4 years ago
Depends on: 983745
You need to log in before you can comment on or make changes to this bug.