If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox failed to download gzipped file: "source file could not be read"; the file has extra fields

RESOLVED DUPLICATE of bug 234031

Status

Core Graveyard
File Handling
RESOLVED DUPLICATE of bug 234031
4 years ago
a year ago

People

(Reporter: Christian Utama, Unassigned)

Tracking

20 Branch
x86_64
All

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.64 Safari/537.31

Steps to reproduce:

When downloading from amazon S3 with gzipped content, firefox failed with error "source file could not be read".

URL: http://gtx-pr-test.s3.amazonaws.com/atkz6h796qh8/data/YG5DMWUGSJWNB9E5GDQ6.bsq

This works on Chrome and IE.

Request headers:

GET http://gtx-pr-test.s3.amazonaws.com/atkz6h796qh8/data/YG5DMWUGSJWNB9E5GDQ6.bsq HTTP/1.1
Host: gtx-pr-test.s3.amazonaws.com
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate
Connection: keep-alive

Response headers:

HTTP/1.1 200 OK
x-amz-id-2: m6CMt67r9h/QUR/Lx/3Vi4McFBc1USfbSsIJItU1/2z3y3sw0KgC7a+PWtjIGRfZ
x-amz-request-id: 33D47E13CEFA83BE
Date: Thu, 09 May 2013 21:24:12 GMT
Content-Encoding: gzip
Last-Modified: Thu, 09 May 2013 00:37:17 GMT
ETag: "059de2a9053909f9b89684c7268f34d4"
Accept-Ranges: bytes
Content-Type: application/octet-stream
Content-Length: 78365
Server: AmazonS3


Actual results:

File failed to download.


Expected results:

File is downloaded.

Comment 1

4 years ago
Maybe it is not gzipped? bug 219526, bug 230153
Summary: Firefox failed to download gzipped file → Firefox failed to download gzipped file: "source file could not be read"
Whiteboard: DUPEME?

Updated

4 years ago
OS: Windows 7 → All

Comment 2

4 years ago
Hm, gunzip does not complain about the file downloaded with "curl" or "curl --raw" or "wget" (all stay gzipped .bsq — maybe that's not considered a gzip content-encoding?).
Component: Untriaged → File Handling
Product: Firefox → Core
(Reporter)

Comment 3

4 years ago
It is a gzipped file, Chrome and IE decompress the file with no error.

The only difference is that the file contains extra header fields (http://www.ietf.org/rfc/rfc1952.txt section 2.3.1.1). The spec says that a decompressor must be able to skip unknown extra fields.

Comment 4

4 years ago
Yes, "file" mentioned "extra field":

$ file YG5DMWUGSJWNB9E5GDQ6.bsq
YG5DMWUGSJWNB9E5GDQ6.bsq: gzip compressed data, extra field, max compression

Maybe bug 329245?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Firefox failed to download gzipped file: "source file could not be read" → Firefox failed to download gzipped file: "source file could not be read"; the file has extra fields
Whiteboard: DUPEME?
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 234031
(Assignee)

Updated

a year ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.