update Firefox OS to version of FreeType that includes Adobe CFF font rasterizer

RESOLVED DUPLICATE of bug 867735

Status

Firefox OS
General
P2
major
RESOLVED DUPLICATE of bug 867735
5 years ago
5 years ago

People

(Reporter: jtd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Adobe recently announced that they have contributed their CFF font rasterizer to FreeType as part of work with Google to improve CFF rendering:

http://blogs.adobe.com/typblography/2013/05/adobe-contributes-cff-rasterizer-to-freetype.html

Whenever is appropriate, it would be great to update to this version of FreeType and use their rasterizer for CFF fonts.  This is especially important in Japan where CFF rendering generally gives better results due to the way hinting is done (in the rasterizer rather than manual hinting data in the font for TTF fonts).  Allowing the OS to use a well-made CFF Japanese font would be a huge win for Japanese users.

Once this code is in the stable branch (if that's what we're currently using) we should take this update.
(Reporter)

Updated

5 years ago
Summary: update to version of FreeType that includes Adobe CFF font rasterizer → update Firefox OS to version of FreeType that includes Adobe CFF font rasterizer
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 867735
You need to log in before you can comment on or make changes to this bug.