javascript can not change the margin

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Marcus, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.43 Safari/537.31

Steps to reproduce:

Bug found. Version: 20.0.1
I can not use javascript to change the margin with fire fox.

In other browsers this line of javascript works...
document.getElementById("container1").style.margin='0px 0px 10px 0px;';


Actual results:

Bug found. Version: 20.0.1
I can not use javascript to change the margin with fire fox.

In other browsers this line of javascript works...
document.getElementById("container1").style.margin='0px 0px 10px 0px;';


Expected results:

Bug found. Version: 20.0.1
I can not use javascript to change the margin with fire fox.

In other browsers this line of javascript works...
document.getElementById("container1").style.margin='0px 0px 10px 0px;';

Comment 1

5 years ago
not need ';' in css properties

Comment 2

5 years ago
Works for me if I remove the ";", does not work with ";" (Web Console says parsing failed).  Should this bug be resolved INVALID?

Comment 3

5 years ago
(I tested with 21.0 Beta)
(Reporter)

Comment 4

5 years ago
(In reply to Alice0775 White from comment #1)
> not need ';' in css properties
Thank you! : )
(Reporter)

Comment 5

5 years ago
I corrected the mistake, as Alice0775 said, and now it's working fine.
Thanks for your patience with me : )
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.