Very high CPU usage on Youtube while video is buffering

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: ehoogeveen, Unassigned)

Tracking

Trunk
x86_64
Windows 7

Details

(URL)

(Reporter)

Description

5 years ago
Youtube exhibits very high CPU usage on my laptop while a video is buffering, making my PC nearly unusable. This doesn't appear to be caused by a recent regression in either Firefox or Flash - I tested back to Firefox 18 and Flash 11.4, and the problem remains unchanged.

Internet Explorer 10 is also affected - however, because IE10 only uses one process and appears to be single threaded, it only uses half of my dual core CPU. In contrast, while the video is buffering, Firefox's main process, the plugin-container process and Flash's sandbox process are all contending for my CPU, causing upwards of 90% CPU usage. Chrome, on the other hand, seems unaffected, sitting pretty at ~10% CPU usage.

Since this doesn't appear to be a regression in Firefox or Flash (aside from the semi-recent addition of the sandbox process), I'm guessing this is a bug in Youtube's Flash-based player. I also don't know how long things have been this way - it seems worse lately but that may simply be because I finally enabled Flash's new sandbox. As such, I'm tentatively filing this as an evangelism bug. However, if there's anything Firefox can do to throttle whatever Flash is doing to cause all this CPU usage, that would be just as good.

STR:
1) From a fresh profile, load up a moderately long video (example: https://www.youtube.com/watch?v=ZWhC_lqbk1E )
2) Pause the video and observe the CPU usage of Firefox, plugin-container and Flash's sandbox process in Task Manager

Expected Behavior:
CPU usage should stay low while the video is paused.

Actual Behavior:
CPU usage is very high while the video is buffering (which can be tracked by looking at the seek bar), then drops when the video is fully loaded.
(Reporter)

Comment 1

5 years ago
Further thoughts: this may simply be caused by downloading at 30 Mbps. Downloading a file with Firefox at that speed does seem to more or less max out one core (Pentium Dual Core @2.3GHz) on this laptop. However, the communication between Firefox, plugin-container and the Flash sandbox make things much worse. All the activity causes the unresponsive plugin dialog to come up when the video is paused, and it plays at a slideshow.
(Reporter)

Comment 2

5 years ago
Youtube now uses the DART protocol for their Flash-based player, which loads in 30 second chunks. This has reduced the problem to a bit of stutter every 30 seconds. You can still disable the DART protocol using the Youtube Center extension, though that probably won't be the case forever. I'll see if profiling says anything more interesting now when I have some time tomorrow.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hi Emanuel. I'm not able to reproduce the issue on FF29 mac, the cpu usage appears to drop right after pausing. Also the CPU usage doesn't peak above 28%, this is on an Early 2011 2.3GHZ i7.
I also tried it on a Windows 7 system running FF29. Win 7 is running in a virtual machine on a 5 year old iMac but still handles it reasonably. Anyway, after pausing the video the CPU usage drops immediately. Not able to reproduce. I'm going to close as WFM but let me know if you're still experiencing the issue.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

4 years ago
I'll retest soon using my laptop; it's certainly possible this got better, though note that my laptop is running Windows 7, so there might be OS-specific slowness involved.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.