see both errors/logs and code lines simultaneously in debugger

RESOLVED DUPLICATE of bug 862558

Status

()

Firefox
Developer Tools: Debugger
RESOLVED DUPLICATE of bug 862558
5 years ago
5 years ago

People

(Reporter: Jim Michaels, Unassigned)

Tracking

20 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130409194949

Steps to reproduce:

see thread in bug 867880. say a function is undefined and you don't know it and you are trying to step though code using step-over. 


Actual results:

there's no way to see that it's undefined unless you do shoe-shining switching between the error panel and the code panel, which take up the same section of graphic/visual space.errors is essentially an unseen panel. so I am caught incessantly swapping back and forth between the errors panel and the code panel.




Expected results:

I would like to see both errors and code lines at the *same time*. it would help my debugging tremendously. and everyone else will breathe a sigh of relief...

Updated

5 years ago
Component: Untriaged → Developer Tools: Debugger
There is already a pause-on-exceptions option in the debugger that is meant exactly for these cases. We have bug 862558 to allow the console to be visible next to the debugger and there is also bug 812764 to show the full error data when pause-on-exceptions is enabled in the debugger. In short, we're already working on it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 862558
You need to log in before you can comment on or make changes to this bug.